Changeset: 380e01fa825f for MonetDB
URL: http://dev.monetdb.org/hg/MonetDB?cmd=changeset;node=380e01fa825f
Modified Files:
        gdk/gdk_logger.c
Branch: transaction-replication
Log Message:

Avoid a filesystem operation when double checking the bak file
Simply use a flag


diffs (28 lines):

diff --git a/gdk/gdk_logger.c b/gdk/gdk_logger.c
--- a/gdk/gdk_logger.c
+++ b/gdk/gdk_logger.c
@@ -747,12 +747,15 @@ logger_update_catalog_file(logger *lg, c
        FILE *fp;
        char filename[BUFSIZ];
        char bak_filename[BUFSIZ];
+       int bak_exists;
 
        snprintf(filename, BUFSIZ, "%s%s", dir, log_filename);
        snprintf(bak_filename, BUFSIZ, "%s.%s", filename, "bak");
 
+       bak_exists = 0;
        /* check if an older file exists and move bak it up */
        if (access(filename, F_OK) != -1) {
+               bak_exists = 1;
                if (GDKmove(dir, filename, NULL, dir, filename, "bak") < 0) {
                        fprintf(stderr, "!ERROR: logger_update_catalog_file: 
rename %s to %s.bak in %s failed\n", filename, filename, dir);
                        return LOG_ERR;
@@ -771,7 +774,7 @@ logger_update_catalog_file(logger *lg, c
                }
 
                /* cleanup the bak file, if it exists*/
-               if (access(bak_filename, F_OK) != -1) {
+               if (bak_exists) {
                        GDKunlink(dir, filename, "bak");
                }
        } else {
_______________________________________________
checkin-list mailing list
[email protected]
https://www.monetdb.org/mailman/listinfo/checkin-list

Reply via email to