"mode desirable" in your interface configurations is almost certainly wrong.

That mode enables the Cisco-proprietary PaGP link aggregation mechanism, which 
IBM probably doesn't support.

"mode active" enables standards-compliant LACP.

"mode on" forces aggregation without any negotiation.

You'll need to find out which mode the IBM server supports (LACP vs forced) and 
do the complimentary thing on the Cisco side.  Generally speaking, LACP is the 
preferred/safer choice.

/hcris


> Sent: Thursday, April 21, 2011 11:19 AM
> To: cisco-nsp@puck.nether.net
> Subject: [c-nsp] Etherchannel between 3560G and IBM power 750
> 
> Does anyone have experience configuring etherchannel between an IBM Power
> 750 and a 3560G? We are not able to establish the etherchannels using 4
> channel x 3 port configuration. From what the consulting is saying here when
> he usually has these set up it never works until the cisco side figures out
> one particular setting that needs to be done to get the channel up. Here is
> the relevant config, Port channel 8 is actually up but that's the link
> between this and another switch/cabinet.
> 
> 
> interface Port-channel1
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel2
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel3
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel4
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel5
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel6
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel7
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Port-channel8
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface GigabitEthernet0/1
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  channel-group 8 mode on
> !
> interface GigabitEthernet0/2
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  channel-group 8 mode on
> !
> interface GigabitEthernet0/3
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 1 mode desirable
> !
> interface GigabitEthernet0/4
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 1 mode desirable
> !
> interface GigabitEthernet0/5
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 1 mode desirable
> !
> interface GigabitEthernet0/6
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 1 mode desirable
> !
> interface GigabitEthernet0/7
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 2 mode desirable
> !
> interface GigabitEthernet0/8
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 2 mode desirable
> !
> interface GigabitEthernet0/9
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 2 mode desirable
> !
> interface GigabitEthernet0/10
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 3 mode desirable
> !
> interface GigabitEthernet0/11
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 3 mode desirable
> !
> interface GigabitEthernet0/12
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 3 mode desirable
> !
> interface GigabitEthernet0/13
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 4 mode desirable
> !
> interface GigabitEthernet0/14
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 4 mode desirable
> !
> interface GigabitEthernet0/15
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 4 mode desirable
> !
> interface GigabitEthernet0/16
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  channel-group 5 mode desirable
> !
> interface GigabitEthernet0/17
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  storm-control broadcast level 30.00
>  storm-control multicast level 70.00
>  no cdp enable
>  channel-group 5 mode desirable
> !
> interface GigabitEthernet0/18
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 1-827
>  switchport mode trunk
>  switchport nonegotiate
>  channel-group 5 mode desirable
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Reply via email to