Hi all,

I have a few problems with configuring route maps in conjunction with BGP.

I have configured a community that advertises all networks except two but
these two networks are still advertised to the peer after doing the clear ip
bgp * command on both peers.

I have read in the Cisco book that route-maps are applied to incoming
packets, therefore I need to configure my route-map on R2, which is
connected to R1 over a serial link (R1 has all the routes to advertise in
the BGP AS).

I'm assuming the logic in my route-map is like this: "if 10.3.2.0/24 is
received in a BGP update, then do not allow that route to be entered into
the BGP route table, however allow all other routes to be enetered into the
BGP route table". Howevere when I do a sh ip bgp it still includes
10.3.2.0/24.

Perhaps R2 will still insert the route into its own route tabel, but not
advertise it out to the next router (R3, which is not connected directly to
R1) - does anybody know? Here is the topology:

R1----------R2-----------R3

Here is the configuration on R2:

router bgp 100
 no synchronization
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 send-community
 neighbor 1.1.1.1 route-map com1 in
!
ip classless
ip route 1.1.1.1 255.255.255.255 192.168.100.1

access-list 3 permit 10.3.2.0 0.0.0.255

route-map com1 permit 10
 match ip address 3
 set community 100
!
route-map com1 permit 20
 set community no-advertise

and on R1:

interface Ethernet0
 ip address 10.2.2.1 255.255.255.0 secondary
 ip address 10.3.2.1 255.255.255.0 secondary
 ip address 10.4.2.1 255.255.255.0 secondary
 ip address 10.5.2.1 255.255.255.0 secondary
 ip address 10.6.2.1 255.255.255.0 secondary
 ip address 10.7.2.1 255.255.255.0 secondary
 ip address 10.8.2.1 255.255.255.0 secondary
 ip address 10.9.2.1 255.255.255.0 secondary
 ip address 10.10.2.1 255.255.255.0 secondary
 ip address 10.1.2.1 255.255.255.0

router bgp 100
 network 10.1.2.0 mask 255.255.255.0
 network 10.2.2.0 mask 255.255.255.0
 network 10.3.2.0 mask 255.255.255.0
 network 10.4.2.0 mask 255.255.255.0
 network 10.5.2.0 mask 255.255.255.0
 network 10.6.2.0 mask 255.255.255.0
 network 10.7.2.0 mask 255.255.255.0
 network 10.8.2.0 mask 255.255.255.0
 network 10.9.2.0 mask 255.255.255.0
 network 10.10.2.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0

TIA,
Matthew.


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=74424&t=74424
--------------------------------------------------
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html

Reply via email to