Andrew,   I think there may be a way around this though if your IOS supports
it.   You can now map an external IP address's port to an internal address's
port...  You may be able to map one external IP port number 25 to internal
IP address 1.1.1.1 and one external IP port 110 to IP address 1.1.1.1 ....
This is just a guess but I do know that you can map external IP address
ports to internal ip address ports..   Heres my sample config for proof...of
course I made changes to protect the innocent.   I have ver 12.03T on a
1750.....
 
HTH
Cory
 
!
!
interface Serial0
 ip address x.x.1.85 255.255.255.252
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 no fair-queue
!
interface FastEthernet0
 ip address 192.168.1.6 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 half-duplex
!
ip nat inside source list 1 interface Serial0 overload
ip nat inside source static udp 192.168.1.5 6699 interface Serial0 6699
ip nat inside source static tcp 192.168.1.5 5632 interface Serial0 5632
ip nat inside source static tcp 192.168.1.4 80 interface Serial0 80
ip nat inside source static tcp 192.168.1.4 110 interface Serial0 110
ip nat inside source static tcp 192.168.1.4 53 interface Serial0 53
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
no ip http server
!
access-list 1 permit any
access-list 2 permit 777.777.777.777
access-list 2 permit 192.168.1.0 0.0.0.255

-----Original Message-----
From: Andrew Larkins [mailto:[EMAIL PROTECTED]]
Sent: Thursday, September 07, 2000 5:59 AM
To: E A Moran; [EMAIL PROTECTED]
Subject: RE: IP NAT


I tried this once and it does not work.... For a static nat to work the
internal ip is translated to one valid external ip.. When I tried to do
exactly as you mentioned I got an error message that the internal ip is
already mapped .
 
 
 

-----Original Message-----
From: E A Moran [mailto:[EMAIL PROTECTED]]
Sent: 06 September 2000 04:24
To: [EMAIL PROTECTED]
Subject: Re: IP NAT


NAT is a one-way procedure by default. You define Inside and Outside
Interfaces. You define which way NAT runs. Check out the NAT commands off of
Cisco's website.
 

-- 
E A Moran
Network Engineer
CNE,MCSE,CCNA,CCDA
TeleCommunication Systems, Inc
www.telecomsys.com <http://www.telecomsys.com> 

"Jin Tam" < [EMAIL PROTECTED] <mailto:[EMAIL PROTECTED]> > wrote in
message [EMAIL PROTECTED]">news:[EMAIL PROTECTED]
<[EMAIL PROTECTED]">news:[EMAIL PROTECTED]> ...

I have a server with an internal IP address of 1.1.1.1 and I have 2 external
addresses 2.2.2.1 and 2.2.2.2.

How can I translate incoming destination addresses 2.2.2.1 and 2.2.2.2 to
1.1.1.1 while keeping outgoing packets from 1.1.1.1 from being translated.

Thanks is advance.

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to