Title: Using BGP: technical questions needing clarification

Hi, all.
I've done quite a bit of reading on BGP Routing and still have some gray areas.
1. Loopback address - if this isn't assigned to a Physical interface, how exactly does this
"eliminate dependency that would otherwise occur when you use the IP address of a
physical interface to configure BGP" when the Physical connection itself between BGP peers
go down? What scenario would give you a practical use out of loopback address?

2. Using a Route Map to set the Weight attribute - what are the range of values you can use?

3. BGP Route Map filtering - consider this configuration:
!Router C
router bgp 300
network 170.10.0.0
neighbor 3.3.3.3 remote-as 200
neighbor 3.3.3.3 route-map STAMP in
route-map STAMP permit 10
match as-path 1 set weight 20
!
route-map STAMP permit 20
match as-path 2
!
route-map STAMP permit 30
set weight 10
!
ip as-path access-list 1 permit ^200$
ip as-path access-list 2 deny _400_
Since only ^200$ is specifically permitted, this still results in all other AS's being denied, right?
So isn't the last entry unnecessary in this config?
3. Load Balancing over Parallel Serial Lines - consider this config:
!Router A
interface loopback 0
ip address 150.10.1.1 255.255.255.0
!
router bgp 100
neighbor 160.10.1.1 remote-as 200
neighbor 160.10.1.1 ebgp-multihop
neighbor 160.10.1.1 update-source loopback 0
network 150.10.0.0
!
ip route 160.10.0.0 255.255.0.0 1.1.1.2
ip route 160.10.0.0 255.255.0.0 2.2.2.2
Is it safe to say that all this does is allow the Router to UTILIZE the 2 serial lines?
Isn't it true that it can't determine how much of each line's bandwidth to use at any given time?
If so, all this does then is perform some kind of "Round-robin" utilizaton of the 2 parallel lines?
As always I'm indebted to all the kind replies. Some time next week I'll stage this BGP configuration
prior to implementing it in the field.

Respectfully,
Elmer Deloso
(757)887-4603



Reply via email to