The key requirement here is to ensure that all IBGP routers can resolve (that is find 
a route to) the BGP provided next hop router for each prefix advertised.  This step is 
fundamental to the proper installation of routes into routing tables.

The first way to accomplish this (in the case where the next hop address for a group 
of prefixes lies on a point to point link) is simply to advertise the external link 
into the IGP domain.

For example, consider this is your edge router

interface s0/0
        ip address 1.1.1.1 255.255.255.252
interface e0
        ip address 10.1.1.1 255.255.255.0 

router bgp 1
        neighbor 1.1.1.2 as 2
        neighbor 10.1.1.2 as 1
        neighbor 10.1.1.2 as 1

router ospf 1
        network 10.1.1.1 0.0.0.0 area 0

(forgive any syntax, haven't configured cisco in a while)

In this case, the peer router in AS 2 will advertise prefixes with a next hope of  
1.1.1.2.  However, assuming as 1 runs OSPF, you can see that the this router does not 
advertise the 1.1.1.0/30 subnet into the ospf domain.  Hence, all  the IBGP neighbors 
will not know how to get to the 1.1.1.2 router and thus all the prefixes they learn 
will not be usable.

To solve this, you can advertise the 1.1.1.0 subnet by adding it to the ospf process 
(network 1.1.1.1 0.0.0.0 area 0) or maybe a redistribute connected etc.  

Or, you can use next hop self "neighbor 10.1.1.2 next-hop-self" to use the 10.1.1.1 
address as the next hop for all prefixes learned from 1.1.1.2 via bgp.

Does that help?

Pete




*********** REPLY SEPARATOR  ***********

On 11/6/2000 at 2:13 AM suaveguru wrote:

>thanks I understand now , but how there is one more
>thing that needs u to further clarify and that is the
>first soluion that you mention , I dont quite
>understand why it will solve the problem 
>
>appreciate if you can elaborate
>
>thanks
>
>suaveguru
>--- Peter Van Oene <[EMAIL PROTECTED]> wrote:
>> When BGP routers learn routes via BGP, they learn
>> two key pieces of information; A destination prefix,
>> and a next hop address.  Within an AS, BGP routers
>> communicate with IBGP.  Within the AS however, the
>> next hop address for each prefix is by default not
>> modified.  That means that all IBGP routers within
>> an AS will maintain a consistent view of the
>> external world.  
>> 
>> However, consider the following.
>> 
>> R1 AS1 <------->  R2 AS2 <-------R2 AS2
>>              EBGP              IBGP
>> 
>> Consider that R1 advertises prefix 10/8 into AS2. 
>> R2 will learn this 10/8 address and the
>> corresponding next hop address.  In this case, lets
>> say that 11/8 is the subnet between R1 and R2 and
>> R1's uses 11.0.0.1 and R2 uses 11.0.0.2.   Hence, R2
>> will publish 10/8 with a next hop of 11.0.0.1 in its
>> routing table.
>> 
>> R2 will then advertise 10/8 via IBGP to R2 with the
>> next hop of 11.0.0.1.  However, as 11/8 is an
>> external point to point link and may not be a subnet
>> that R2 is aware of.  If this is the case, R2 will
>> not be able to resolve a route toward 11/8 and thus
>> will be unable to post the route due to the rules of
>> BGP.
>> 
>> Two solutions exist to solve this problem (well two
>> pop into my mind).  The first way would be to have
>> R2 advertise the external link (11/8 in this case)
>> into the AS so that all IBGP routers will learn it. 
>> This however increases the size and complexity of
>> the IGP within the AS.
>> 
>> The second option is to have R2 replace the next hop
>> address with his own address.   Naturally, his own
>> address will be known throughout the AS (BGP depends
>> on TCP so this has to be the case) and thus when R2
>> receives the 10/8 advertisement, it will see R2's
>> interface as the next hop and thus be able to
>> resolve the bgp next hop and post the route.
>> 
>> I hope this makes sense :)
>> 
>> Pete
>> 
>> 
>> 
>> 
>> *********** REPLY SEPARATOR  ***********
>> 
>> On 11/3/2000 at 11:58 AM suaveguru wrote:
>> 
>> >hi , 
>> >
>> >Anyone knows what does next-hop-self in bgp means
>> >please explain to me 
>> >
>> >thanks
>> >
>> >suaveguru
>> >
>> >__________________________________________________
>> >Do You Yahoo!?
>> >>From homework help to love advice, Yahoo! Experts
>> has your answer.
>> >http://experts.yahoo.com/
>> >
>> >_________________________________
>> >FAQ, list archives, and subscription info:
>> http://www.groupstudy.com/list/cisco.html
>> >Report misconduct and Nondisclosure violations to
>> [EMAIL PROTECTED]
>> 
>> 
>> 
>> _________________________________
>> FAQ, list archives, and subscription info:
>> http://www.groupstudy.com/list/cisco.html
>> Report misconduct and Nondisclosure violations to
>[EMAIL PROTECTED]
>
>
>__________________________________________________
>Do You Yahoo!?
>Thousands of Stores.  Millions of Products.  All in one Place.
>http://shopping.yahoo.com/
>
>_________________________________
>FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
>Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to