Whitaker,
                 The easier way would be to use the null route or as it
better referred to as the blackhole route.  Of course if you're routing
traffic for the subnets /25 then your igp would have picked up the those
subnets. The use of any of the various commands "redistribute connected
subnets" redistribute static subnets"  if the interface is locally defined
or learned through the IGP would in effect provide a route to that traffic
once your provider got the external (BGP) traffic to you AS(routing domain).

Personally I would use the basic configuration:
!
router ospf(igp) <AS #>
redistribute static subnets
redistribute connected subnets
network <ospf defined interfaces/networks>
!
router bgp <AS #>
redistribute ospf <AS #> <add. commands>
neighbor <ISP eBGP peer address> remote-as <AS #>
neighbor <ISP eBGP peer address> distribute-list 1 out
!
access-list 1 deny  1.1.1.0 0.0.0.128
access-list 1 deny 1.1.1.128 0.0.0.128
access-list 1 permit any
!
ip route 1.1.1.0 255.255.255.0 null0


This would accomplish everything you needed to do... unless of course you
were
given specific requirements to make use of route-map statements.  Good  BGP
practices
suggest that the provider would have a filter in place to limit what routes
he learns from you
anyway.

HTH

Nigel...


----- Original Message -----
From: whitaker <[EMAIL PROTECTED]>
To: [EMAIL PROTECTED] <[EMAIL PROTECTED]>
Sent: Sunday, December 03, 2000 1:33 AM
Subject: bgp question and subnetting


> Scenario:
> Let's say you have a class C subnet that you break off into two smaller
> networks:
>
> 1.1.1.0/24 = 1.1.1.0/25 + 1.1.1.128/25
>
> Problem:
> You are announcing this through BGP, but your provider only allows you to
> advertise full class C addresses.  The problem lies in that you have to
> announce this network as 1.1.1.0/24 but still get traffic to 1.1.1.0/25 &
> 1.1.1.128/25.
>
> Solution:
> So, there are two ways to do this:
>
> 1) Use an aggregate-address with a suppress map to filter this.
>
> router bgp <as>
> network 1.1.1.0 mask 255.255.255.128
> network 1.1.1.128 mask 255.255.255.128
> aggregate-address 1.1.1.0 255.255.255.0 suppress-map mysupressmap
> !
> route-map mysuppressmap permit 10
> match ip address 20
> !
> access-list 20 permit 1.1.1.0 0.0.0.128
> access-list 20 permit 1.1.1.128 0.0.0.128
> !
> int vlan 1
> ip add 1.1.1.1 255.255.255.128
> no shut
> !
> int vlan 2
> ip add 1.1.1.129 255.255.255.128
> no shut
>
>
> 2) Use null routes
>
> router bgp <as>
> network 1.1.1.0 mask 255.255.255.0
> !
> ip route 1.1.1.0 255.255.255.0 null 0
> !
> int vlan 1
> ip add 1.1.1.1 255.255.255.128
> no shut
> !
> int vlan 2
> ip add 1.1.1.129 255.255.255.128
> no shut
>
>
> Question:
> Which way do you all feel is better?
>
> I read in Boson's test that the preferred way is to use aggregate
addresses,
> but this seems to be a much more complex way to do what a simple null
route
> can accomplish?  Thought / comments?
>
> _________________________________
> FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to