This may be more info than you want, but here is some info I've put togther
that I plan on using in one of our training classes.




Cisco 6500 Series MSFC Native IOS Layer 3 Switching


 This concept blends switching and routing into one platform. The Native IOS
mode on this platform allows the switching and routing to be configured and
managed through the familiar and powerful IOS user
interface.

Currently the 6500 switch/routers are shipped configured in the Hybrid mode.
This mode requires configuration on two different interfaces. One interface
using the XDI set commands configures the switching function. The other
interface uses the familiar Cisco IOS command set for configuring routing
functions.



MSFC Native IOS Mode Operating Concepts


1st CPU is the (SP) switch processor, 150Mhz R4700 used by the Layer-2
oriented Supervisor card
2nd CPU is the (RP) route processor, 200Mhz R5000 (This is the same as the
NPE-200 from a 7200 router)

In native mode IOS both CPU¡¦s run full IOS software. In native IOS mode the
RP acts as the primary CPU, and the SP acts as the secondary processor.

Both CPU¡¦s work in tandem to enhance performance. The SP CPU concentrates
on port-level management (such as link up/down) and layer-2 protocols such
as Spanning-Tree, VTP, and DTP. The RP CPU performs duties such as routing
the first packet in every IP or IPX flow (or all packets for protocols that
are not supported by the NFFC)

The two CPUs boot from different binary image files. First, the SP CPU takes
control and loads an image from flash memory. Then, it passes control to the
RP image (along with passing control of the console port) so that it can
boot another image and take over as the primary CPU for the entire device.

The native IOS mode MSFC maintains two sets of NVRAM for storing
configuration information. These two NVRAM storage locations also correspond
to two different configuration modes: VLAN database configuration mode and
normal IOS configuration mode.

--The VLAN database  (applied immediately upon exit)
--The local switch configuration (must use write mem or copy run start to
apply)


To enter VLAN database configuration mode enter ¡§vlan database¡¨ at the
router# prompt. The prompt will be modified to router#(vlan) when you enter
this mode. Type exit to return to native IOS and apply changes. This command
mode is where you add and name VLANs.





Native IOS Mode Interface Types


Routed interfaces

--Routed physical interfaces
--Routed SVI interfaces (SVI= switch virtual interface)


Switched interfaces (also called switchport interfaces)

--Access switchport interfaces
--Trunk switchport interfaces


Routed physical interfaces

In this configuration very port receives its own IP and/or IPX address.

Router# conf t
Router(config)#int fa3/1
Router(config-if)# ip address 10.3.1.1 255.255.0.0
Router(config-if)#end
Router#


Access switchport interfaces

To place several ports into the same IP subnet you will need to convert the
ports from a routed interface to a switched interface. Use the command
¡§switchport¡¨ under config-if section to activate this. An access
switchport only supports one VLAN.

Switchports automatically default to VLAN 1. However, this assignment is not
made until after the switchport command has been entered.


Placing two interfaces in the same VLAN (Default= VLAN 1)

Router# conf t
Router(config)#int fa3/1
Router(config-if)# switchport
Router(config)#int fa3/2
Router(config-if)# switchport
Router(config-if)#end
Router#


Placing two interfaces in the same VLAN for VLAN 2 (You can¡¦t apply IP
addressing directly to these interfaces as these are layer 2 ports.

Router# conf t
Router(config)#int fa3/1
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 2
Router(config)#int fa3/2
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 2
Router(config)#int range 5/1-5, 6/1-24
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 3
Router(config-if)#end
Router#



Routed SVI interfaces

To assign an IP address to 3/1 and 3/2 above you will need a separate
interface that can act as the routed interface on behalf of both
switchports. This is where the concept of the Switch Virtual Interface (SVI)
applies. SVI¡¦s use names like interface VLAN 1 or interface VLAN 2. The two
switch ports from above 3/1 and 3/2 are integrated into one layer three
interface and given layer-3 addressing such as IP addresses as needed. To
create a SVI, just enter the command ¡§interface VLAN #¡¨

Router# conf t
Router(config)#int vlan 1
Router(config-if)#ip address 10.1.1.1 255.255.0.0
Router(config)#int vlan 2
Router(config-if)#ip address 10.2.1.1 255.255.0.0
Router(config-if)#end
Router#



Trunk switchport interfaces

Trunk interfaces can be created to carry multiple VLANs using ISL or 802.1Q
encapsulations.

Router# conf t
Router(config)#int fa3/1
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation isl
Router(config-if)# switchport trunk allowed vlan remove 11-1000
Router(config-if)#end
Router#















Other Switch Info.


Cisco 2948G / 4006/5000/6500 Hybrid mode (XDI)

Show Config (Ctrl-C to Break) ¡V Show configuration (changes from default
values) on the unit.
Show Port ¡V Displays a quick summary of all cards and ports and their
status.
Show Port 2 - Displays all ports on card 2 and their settings/status

Set int{erface} sc0{port} 1{VLAN#} 10.100.23.2[Address}
255.255.0.0{Subnet} ¡V Set IP Address and
Subnet mask on switch.
Set int{erface} sc0{port} up ¡V Turn Port Administratively On
Set ip route default {route/gateway as} 10.100.30.1 ¡V Set Default Gateway
for switch
Set spantree disable ¡V Disable Spantree
Set system name [Name] ¡V Set switch name
Set pass - Set password to login to switch
Set enablepass ¡V Set password to enter enable mode.
Set Time Wednesday 05/24/2000 12:40:45 ¡V Set date to 5/24/2000 and time to
12:40:45.
Set port duplex 2/1{port} full{duplex} ¡V Set duplex to full on port 1 in
card 2.
Set {port} enable ¡V Enable port if disabled.
Set port speed 2/1{port} 100{MBps} ¡V Set speed to 100Mbps on port 1 card 2.
Set port name 2/1{port} Cat2948G{name} ¡V Set name label to specified value
(Cat2948G) on port 1 in
card 2.
Set system modem enable ¡V Enable system modem capacities.

Cisco 2900/3500 (IOS)

Show cdp neighbor ¡V Displays all Cisco devices directly attached to this
switch.

Enable ¡V Takes you into enable mode (usually after you enter a password).
Config T ¡V Takes you into terminal configuration mode.
Hostname C2924{name}- Changes the name of switch.
Int Vlan1 - Change to Vlan1 Interface.
IP address 10.100.23.3{IP Address} 255.255.0.0{Subnet Mask} {NO GATEWAY} ¡V
Sets IP Address
(10.100.23.3) and Subnet Mask (255.255.0.0) for the switch.
No shut - Administratively Turn port on.
IP Default-Gateway 10.100.30.1 ¡V Defines switch default gateway/router to
10.100.30.1
Username Administrator{name} Password code{password} ¡V Define login ID of
administrator with a
password of code.
Enable secret lan2000{password} ¡V Setup enable password for the switch and
save it encrypted in the
config files.
No spantree - Turn off spantree functionality.
Interface FA{stEthernet}0/1{Port} ¡V Go interface configuration screen for
FA0/1 port.
Duplex {auto, full, half} ¡V Set duplex for this port as any of the listed
choices.
Speed {10,100,Auto} ¡V Set speed for this port to any of the listed choices.
Description {Description of Port} ¡V Set description/label for port as
whatever you enter after the
command.
Line VTY 0 4 ¡V Begin setup of Telnet sessions 0 through 4 (5 total
sessions)
 Exec-timeout 0 0 ¡V Set timeout parameters for telnet session
 Password code {password} ¡V set password for entering telnet session to
code provided
 Login ¡V force login before initializing telnet session.
Write ¡V Save configuration to what is running in memory.  You will lose
everything you change if power is
lost without saving data in this manner.





















""kw.wong(Ah Wang)^_^"" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> Hi All :
>
> I 've don't the cisco note about the MSM install/config.
> But, some consep don't know ?
>
> 1 ) what is g/0/0/0 -g4/0/0/0
>
> 2) how to assign the ip address in each interface ant sub interface port
> channel 1.x
>
> 3) how to do the vlan routing between in vlan 1 to vlan 4.
>
> 4 )any exiting for me reference.
>
> Thanks !
>
> _________________________________
> FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>


_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to