If I understand your topology, the problem is that you are running RIP and
IGRP with a discontiguous classfull network.  Let me rephrase that.  <g>

It appears that your network looks like this:

A 10.1.0.0 --------- 192.168.10.0 ---------- B 10.2.0.0

RIP and IGRP cannot pass subnet mask information in their routing updates. 
This means that router A above thinks that the entire 10.0.0.0 network --not
just 10.1.0.0/16-- resides to its left. Router B think the entire
10.0.0.0/16 network resides to its right.  These routers will get very
confused and will behave in the manner that you're seeing.

To correct this behavior you must run a classless routing protocol that
includes subnet mask information in its updates, so your options are eigrp,
ospf, and is-is.  This will solve your problem.

I hope that makes sense.  I just woke up and I'm still pretty groggy!

Regards,
John

>  Hi All - In my network enviroment, I have LANs with 10.x.0.0/16 networks
and
>  WAN with 192.168.10.0/24.  I use RIP for LAN and IGRP for WAN.  On RIP, I
>  redistribute IGRP, and vice versa, on IGRP I redistribute RIP.  However,
I
>  cannot ping from one LAN to the other LAN.  If I put a static route to
>  specify the next hop, then I can ping the other LAN.  Is there a way to
have
>  the network learn all the LAN dynamically, instead of static route?  I am
>  running IOS ver 11.3 on both routers.  Here is my configuration:
>  
>  -----------------------------------------------------------------------
>  Router1#
>  !
>  interface Ethernet0/0
>    ip address 10.1.100.100 255.255.0.0
>  !
>  !
>  interface Serial0/0
>    ip address 192.168.10.1 255.255.255.0
>    encapsulation frame-relay
>    keepalive 5
>  !
>  !
>  router rip
>    redistribute igrp 200
>    passive-interface Serial0/0
>    passive-interface Serial0/1
>    network 10.0.0.0
>  !
>  router igrp 200
>    redistribute rip
>    passive-interface Ethernet0/0
>    network 192.168.10.0
>    no default-information in
>    no default-information out
>  !
>  ......
>  !
>  Router1#
>  
> 
----------------------------------------------------------------------------
>  ------
>  
>  Router2#
>  !
>  interface Ethernet0/0
>    ip address 10.2.100.100 255.255.0.0
>  !
>  !
>  interface Serial0/0
>    ip address 192.168.10.2 255.255.255.0
>    encapsulation frame-relay
>    keepalive 5
>  !
>  !
>  router rip
>    redistribute igrp 200
>    passive-interface Serial0/0
>    passive-interface Serial0/1
>    network 10.0.0.0
>  !
>  router igrp 200
>    redistribute rip
>    passive-interface Ethernet0/0
>    network 192.168.10.0
>    no default-information in
>    no default-information out
>  !
>  ......
>  !
>  Router2#
> 
----------------------------------------------------------------------------
>  --
>  
>  Thanks All in advance!
>  
>  
>  
>  
>  _________________________________
>  FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
>  Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]





_______________________________________________________
Send a cool gift with your E-Card
http://www.bluemountain.com/giftcenter/


_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to