Here's what I did.  Changed the access-list to deny and changed the
wildcards from 3 to 255 since IGRP redistributes the classful version of
173.5.8.x network.  See below:

interface BRI0/0
 ip address 173.5.8.1 255.255.255.252
 ip ospf demand-circuit
 ...

router ospf 1
 redistribute igrp 100 metric 100 subnets route-map stuff
 network 173.5.8.0 0.0.0.3 area 3

access-list 15 deny 173.5.8.0 0.0.0.255
access-list 15 permit any

route-map stuff deny 5
 match ip address 15
!
route-map stuff permit 10
!

--------------------
Jerry "Been there.  Done that" Toomey




--- Andrew Larkins <[EMAIL PROTECTED]> wrote:
> 
> what about blocking the 224.0.0.6 and 224.0.0.5 as interesting traffic.
> I do
> that by default so that updates do not bring up the link unnecessarily
> -----Original Message-----
> From: Alan Basinger [mailto:[EMAIL PROTECTED]]
> Sent: 27 March 2001 22:31
> To: Mask Of Zorro; [EMAIL PROTECTED];
> [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]
> Subject: RE: bri flapping with demand cirquit/igrp redistribution
> 
> 
> Your correct Z filter the bri subnet from redistribution into IGRP and
> your
> LSA's should not continue to bring the link up.
> 
> Alan
> 
> -----Original Message-----
> From: Mask Of Zorro [mailto:[EMAIL PROTECTED]]
> Sent: Tuesday, March 27, 2001 2:32 PM
> To: [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
> [EMAIL PROTECTED]
> Subject: Re: bri flapping with demand cirquit/igrp redistribution
> 
> 
> Redistribution brings it up.
> 
> What happens is, the link is brought up and OSPF forms an adjacency.
> Then,
> since it is a demand circuit, periodic LSA's are squelched and OSPF
> routes
> associated with those LSA's do not age out of the routing table. Then,
> the
> layer 2 portion of the link drops, since there is no interesting
> traffic.
> 
> Once the link drops, whatever protocol you are redistributing into OSPF
> sees
> it's link drop, and changes its tables in accordance with the topology
> change. This change gets redistributed into OSPF, and OSPF floods LSA's
> out
> announcing the change. These LSA's bring up the link while OSPF
> converges.
> Then, after a while, things are stable again, and the link drops - and
> guess
> what?  That's right! The whole thing starts again...
> 
> There are ways to stop it.
> 
> Z
> >From: "George Zhang" <[EMAIL PROTECTED]>
> >Reply-To: "George Zhang" <[EMAIL PROTECTED]>
> >To: <[EMAIL PROTECTED]>, <[EMAIL PROTECTED]>,
> ><[EMAIL PROTECTED]>, <[EMAIL PROTECTED]>,
> ><[EMAIL PROTECTED]>, <[EMAIL PROTECTED]>, <[EMAIL PROTECTED]>,
> >  <[EMAIL PROTECTED]>, <[EMAIL PROTECTED]>,
> ><[EMAIL PROTECTED]>, <[EMAIL PROTECTED]>
> >Subject: Re: bri flapping with demand cirquit/igrp redistribution
> >Date: Tue, 27 Mar 2001 13:50:52 -0600
> >
> >I also had the same problem a few days ago.  Here is how I fixed it:
> >
> >1. Isolate the problem by shutting  down all other interfaces besides
> the
> >interfaces
> >     between the two related routers;
> >
> >2. Disable all other routing protocols (non-OSPF ones);
> >
> >3. Turn off IGRP redistribution to OSPF;
> >
> >3. Now, verify the ISDN demand circuit.  It should be quiet now.
> >
> >4. Now, start unshut the interfaces you have shut down one by one and
> >verify
> >     that the ISDN demand circuit.  It should might come up briefly but
> it
> >should go
> >     down and keep quiet after some interfaces are unshut.  If the ISDN
> >line
> >    keep dialing, you should know which interface is causing the
> problem.
> >
> >5. If the ISDN line is still quiet after you unshut all interfaces,
> turn on
> >your other router
> >     protocols such as IGRN, RIP, etc one by one.  Again, verify the
> IDN
> >line after
> >     each change as above.
> >
> >5. If the ISDN line is still quiet after you enable all other routing
> >protocols, turn on your
> >    redistribution one by one.  Again verify ISDN line along the way.
> >
> >If you follow these steps, you should be able to pin down what is
> causing
> >your ISDN
> >line to stay up.
> >
> >Hope it helps.
> >
> >George Zhang
> >
> >
> > >>> "Donald B Johnson Jr" <[EMAIL PROTECTED]> 03/27/01 03:33PM
> >>>
> >It may keep the connection open though even after there is no
> intresting
> >traffic.
> >Don
> >----- Original Message -----
> >From: Alan Basinger <[EMAIL PROTECTED]>
> >To: Chris Larson <[EMAIL PROTECTED]>; perez claude-vincent
> ><[EMAIL PROTECTED]>; Ya Wen <[EMAIL PROTECTED]>;
> Patrick
> >Murphy <[EMAIL PROTECTED]>; Leah Lynch <[EMAIL PROTECTED]>;
> 'Jay
> >Chandradas' <[EMAIL PROTECTED]>; 'Bob Boone' <[EMAIL PROTECTED]>;
> ><[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>
> >Sent: Saturday, March 24, 2001 8:37 AM
> >Subject: RE: bri flapping with demand cirquit/igrp redistribution
> >
> >
> > > CDP may work at layer 2 but if the line is brought up because of web
> >traffic
> > > CDP packets would then traverse the line consume a small amount of
> > > bandwidth.
> > > I have installed a few ISDN DDR VPN's without turning off CDP and
> never
> >had
> > > and issue but also didn't think about the bandwidth consumption at
> the
> >time.
> > >
> > > Alan
> > >
> > > -----Original Message-----
> > > From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf
> Of
> > > Chris Larson
> > > Sent: Saturday, March 24, 2001 9:00 AM
> > > To: perez claude-vincent; Ya Wen; Patrick Murphy; Leah Lynch; 'Jay
> > > Chandradas'; 'Bob Boone'; [EMAIL PROTECTED];
> [EMAIL PROTECTED]
> > > Subject: RE: bri flapping with demand cirquit/igrp redistribution
> > >
> > >
> > > It may not, I have just always disabled it on dialer links as a
> habit.
> >It
> > > makes sense that it shouldn't since the dialer-list defines layer 3
> >traffic
> > > only. You could always put an access-list on the dialer interface
> >permitting
> > > all traffic with the log statement to see exactly what is trying to
> get
> > > accross the line. It will output to the console if you are consoled
> in.
> >That
> > > may help you to see what is bringing the line up.
> > >
> > > -----Original Message-----
> > > From: perez claude-vincent [mailto:[EMAIL PROTECTED]]
> > > Sent: Saturday, March 24, 2001 9:22 AM
> > > To: Ya Wen; Patrick Murphy; Leah Lynch; 'Jay Chandradas'; 'Chris
> > > Larson'; 'Bob Boone'; [EMAIL PROTECTED]; [EMAIL PROTECTED]
> > > Subject: RE: bri flapping with demand cirquit/igrp redistribution
> > >
> > >
> > > Can somebody tell me how come CDP may bring the line
> > > up? As you know, it works only in layer 2 as said
> > > before. Your dialer-list works at layer 3 & 4 only.
> > >
> > > Did I miss something? :-(
> > >
> > >
> > >
> > > --- Ya Wen <[EMAIL PROTECTED]> wrote:
> > > > Try remove the "log" from the access-list 15
> > > > associated with the route-map
> > > > stuff. Also, you do not need the summary-address
> > > > under OSPF.
> > > >
> > > > -Ya
> > > >
> > > > -----Original Message-----
> > > > From: [EMAIL PROTECTED]
> > > > [mailto:[EMAIL PROTECTED]]On Behalf Of
> > > > Patrick Murphy
> > > > Sent: Friday, March 23, 2001 5:04 PM
> > > > To: Leah Lynch; 'Jay Chandradas'; 'Chris Larson';
> > > > 'Bob Boone';
> > > > [EMAIL PROTECTED]; [EMAIL PROTECTED]
> > > > Subject: Re: bri flapping with demand cirquit/igrp
> > > > redistribution
> > > >
> > > >
> > > > Also check the BRI interface and see if you see
> > > > IPCDP, it should disapper
> > > > when you no cdp en!
> > > >
> > > > Patrick
> > > >
> > > > ----- Original Message -----
> > > > From: "Leah Lynch" <[EMAIL PROTECTED]>
> > > > To: "'Jay Chandradas'" <[EMAIL PROTECTED]>; "'Chris
> > > > Larson'"
> > > > <[EMAIL PROTECTED]>; "'Bob Boone'"
> > > > <[EMAIL PROTECTED]>;
> > > > <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>
> > > > Sent: Friday, March 23, 2001 7:45 PM
> > > > Subject: RE: bri flapping with demand cirquit/igrp
> > > > redistribution
> > > >
> > > >
> > > > > I think you normally disable CDP in dialup lines
> > > > for efficiency.
> > > > >
> > > > > Leah
> > > > >
> > > > > -----Original Message-----
> > > > > From: [EMAIL PROTECTED]
> > > > [mailto:[EMAIL PROTECTED]]On Behalf Of
> > > > > Jay Chandradas
> > > > > Sent: Friday, March 23, 2001 2:57 PM
> > > > > To: Chris Larson; Bob Boone; [EMAIL PROTECTED];
> > > > > [EMAIL PROTECTED]
> > > > > Subject: Re: bri flapping with demand cirquit/igrp
> > > > redistribution
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > I am not sure CDP will keep the line up ? And ur
> > > > interesting traffic is
> > > > > permit ip any any . I dont think CDP will keep the
> > > > line up. When u do a
> > > > > debug ip pack.. u can nvr see CDP.. CDP is layer
> > > > 2.
> > > > >
> > > > > my 0.02
> > > > >
> > > > > ----- Original Message -----
> > > > > From: "Chris Larson" <[EMAIL PROTECTED]>
> > > > > To: "Bob Boone" <[EMAIL PROTECTED]>; "Jay
> > > > Chandradas"
> > > > <[EMAIL PROTECTED]>;
> > > > > <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>
> > > > > Sent: Friday, March 23, 2001 2:40 PM
> > > > > Subject: RE: bri flapping with demand cirquit/igrp
> > > > redistribution
> > > > >
> > > > >
> > > > > > Will CDP keep the line up? Turn off CDP.
> > > > > >
> > > > > > -----Original Message-----
> > > > > > From: [EMAIL PROTECTED]
> > > > [mailto:[EMAIL PROTECTED]]On Behalf Of
> > > > > > Bob Boone
> > > > > > Sent: Friday, March 16, 2001 5:30 PM
> > > > > > To: Jay Chandradas; [EMAIL PROTECTED];
> > > > [EMAIL PROTECTED]
> > > > > > Subject: Re: bri flapping with demand
> > > > cirquit/igrp redistribution
> > > > > >
> > > > > >
> > > > > > Yes i do have passive BRI on IGRP, and also, the
> > > > way it is done now, it
> > > > > > restricts ALL networks, if you look at the
> > > > access-list 15 it has one
> > > > > > statement and then explisit deny all.
> > > > > > still not working.
> > > > > >
> > > > > > ----- Original Message -----
> > > > > > From: "Jay Chandradas" <[EMAIL PROTECTED]>
> > > > > > To: "Netguy" <[EMAIL PROTECTED]>;
> > > > <[EMAIL PROTECTED]>;
> > > > > > <[EMAIL PROTECTED]>
> > > > > > Sent: Friday, March 16, 2001 12:22 PM
> > > > > > Subject: Re: bri flapping with demand
> > > > cirquit/igrp redistribution
> > > > > >
> > > > > >
> > > > > > > 1. DO u have a passive interface on bri0 under
> > > > router IGRP
> > > > > > >
> > > > > > > 2. I wud do this way !! when u r redisributing
> > > > into OSPG .. allow only
> > > > > the
> > > > > > > IGRP networks ( including the network conneted
> > > > with is running IGRP )
> > > > > > >
> > > > > > > Jay
> > > > > > >
> > > > > > > when u r redistributing into
> > > > > > > ----- Original Message -----
> > > > > > > From: "Netguy" <[EMAIL PROTECTED]>
> > > > > > > To: <[EMAIL PROTECTED]>;
> > > > <[EMAIL PROTECTED]>
> > > > > > > Sent: Friday, March 16, 2001 12:01 PM
> > > > > > > Subject: bri flapping with demand cirquit/igrp
> > > > redistribution
> > > > > > >
> > > > > > >
> > > > > > > > > Hello all you happy people.
> > > > > > > > > Router A has ospf/igrp mutual
> > > > redistribution and bri
> > > > > > > > > int dialing elsewhere with demand circuit.
> > > > it keeps
> > > > > > > > > flapping.
> > > > > > > > > i followed someone's advice and created a
> > > > route/map
> > > > > > > > > filter to filter out bri network from igrp
> > > > > > > > > redistributing back into ospf.
> > > > > > > > > what the hell am i doing wrong? i know its
> > > > a big
> > > > > > > > > thing
> > > > > > > > > that lots of people had problems with.
> > > > > > > > > here's the key configs:
> > > > > > > > > interface BRI0/0
> > > > > > > > >  ip address 173.5.8.1 255.255.255.252
> > > > > > > > >  encapsulation ppp
> > > > > > > > >  ip ospf demand-circuit
> > > > > > > > >  dialer idle-timeout 15
> > > > > > > > >  dialer map ip 173.5.8.2 name R5 broadcast
> > > > 8667007
> > > > > > > > >  dialer map ip 173.5.8.2 name R5 broadcast
> > > > 8667008
> > > > > > > > >  dialer load-threshold 128 outbound
> > > > > > > > >  dialer-group 1
> > > > > > > > >  isdn switch-type basic-dms100
> > > > > > > > >  isdn spid1 9258667005
> > > > > > > > >  isdn spid2 9258667006
> > > > > > > > >  ppp authentication chap
> > > > > > > > >  ppp chap hostname CCIE
> > > > > > > > >  ppp multilink
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > router ospf 1
> > > > > > > > >  log-adjacency-changes
> > > > > > > > >  area 0 authentication message-digest
> > > > > > > > >  area 0 range 173.5.1.0 255.255.255.0
> > > > > > > > >  summary-address 173.5.10.0 255.255.255.0
> > > > > > > > >  redistribute igrp 100 metric 100 subnets
> > > > route-map
> > > > > > > > > stuff
> > > > > > > > >  network 1.1.1.0 0.0.0.3 area 0
> > > > > > > > >  network 173.5.1.0 0.0.0.15 area 0
> > > > > > > > >  network 173.5.7.0 0.0.0.7 area 3
> > > > > > > > >  network 173.5.8.0 0.0.0.3 area 3
> > > > > > > > >  network 173.5.10.0 0.0.0.127 area 3
> > > > > > > > >  network 173.5.17.0 0.0.0.255 area 0
> > > > > > > > > access-list 15 permit 173.5.8.0 0.0.0.3
> > > > log
> > > > > > > > > route-map stuff deny 5
> > > > > > > > >  match ip address 15
> > > > > > > > > !
> > > > > > > > > route-map stuff permit 10
> > > > > > > > >  set tag 4
> > > > > > > > >
> > > > > > > > >
> > > > __________________________________________________
> > > > > > > > > Do You Yahoo!?
> > > > > > > > > Get email at your own domain with Yahoo!
> > > > Mail.
> > > > > > > > > http://personal.mail.yahoo.com/
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > __________________________________________________
> > > > > > > > Do You Yahoo!?
> > > > > > > > Get email at your own domain with Yahoo!
> > > > Mail.
> > > > > > > > http://personal.mail.yahoo.com/
> > > > > > > >
> > > > > > > >
> > > >
> > > _______________________________________________________
> > > > > > > > To unsubscribe from the CCIELAB list, send a
> > > > message to
> > > >
> > > === message truncated ===
> > >
> > >
> > > =====
> > >
> > > Vincent
> > >
> > >
> > > __________________________________________________
> > > Do You Yahoo!?
> > > Get email at your own domain with Yahoo! Mail.
> > > http://personal.mail.yahoo.com/
> > >
> > > **NOTE** All LAB SWAP messages should now be sent to the
> > > LAB SWAP Message board on groupstudy.com.
> > > _______________________________________________________
> > > To unsubscribe from the CCIELAB list, send a message to
> > > [EMAIL PROTECTED] with the body containing:
> > > unsubscribe ccielab
> > >
> > > _________________________________
> > > FAQ, list archives, and subscription info:
> >http://www.groupstudy.com/list/cisco.html
> > > Report misconduct and Nondisclosure violations to
> [EMAIL PROTECTED]
> >
> >**NOTE** All LAB SWAP messages should now be sent to the
> >LAB SWAP Message board on groupstudy.com.
> >_______________________________________________________
> >To unsubscribe from the CCIELAB list, send a message to
> >[EMAIL PROTECTED] with the body containing:
> >unsubscribe ccielab
> >
> >**NOTE** All LAB SWAP messages should now be sent to the
> >LAB SWAP Message board on groupstudy.com.
> >_______________________________________________________
> >To unsubscribe from the CCIELAB list, send a message to
> >[EMAIL PROTECTED] with the body containing:
> >unsubscribe ccielab
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com
> 
> _________________________________
> FAQ, list archives, and subscription info:
> http://www.groupstudy.com/list/cisco.html
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
> 
> **NOTE** All LAB SWAP messages should now be sent to the
> LAB SWAP Message board on groupstudy.com.
> _______________________________________________________
> To unsubscribe from the CCIELAB list, send a message to
> [EMAIL PROTECTED] with the body containing:
> unsubscribe ccielab


=====
Jerry Toomey

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/?.refer=text

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to