This one's kicking my ass.  Should be simple, but apparently it isn't.  I've
got three routers in a frame relay configuration: R3 is the hub, R4 and R5
are the spokes.  For some reason the routes aren't being exchanged the way
they should be, in spite of the fact that all the OSPF adjacencies *appear*
to be there.  R5 isn't getting any OSPF routes, and yet R4 (which has the
exact same configuration) is getting a couple from R3.  Below you'll find
the configs, routing tables, and neighbor statuses for all three routers.

Router 3 (hub):

R3#sho run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 192.168.1.9 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 10.0.0.3 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
 frame-relay interface-dlci 101
 frame-relay interface-dlci 102
!
interface Serial0.2 point-to-point
 ip address 192.168.1.57 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
 frame-relay interface-dlci 103
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.8 0.0.0.3 area 0
 network 192.168.1.56 0.0.0.3 area 0
!
ip classless
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R3#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0.1
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
C       192.168.1.56/30 is directly connected, Serial0.2
C       192.168.1.8/30 is directly connected, Loopback0
O       192.168.1.13/32 [110/65] via 10.0.0.4, 18:42:08, Serial0.1
R3#sho ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.0.0.5          1   FULL/DROTHER    00:01:53    10.0.0.5        Serial0.1
192.168.1.13      1   FULL/DR         00:01:50    10.0.0.4        Serial0.1


****************************************************************************
*******

Router 4 (spoke):

R4#sho run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
boot system flash
!
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 192.168.1.13 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Ethernet0
 ip address 10.1.1.8 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.0.0.4 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
 frame-relay interface-dlci 101
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.12 0.0.0.3 area 0
!
ip classless
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R4#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
C       10.0.0.0 is directly connected, Serial0.1
C       10.1.1.0 is directly connected, Ethernet0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.56/30 [110/128] via 10.0.0.3, 18:43:44, Serial0.1
O       192.168.1.9/32 [110/65] via 10.0.0.3, 18:43:44, Serial0.1
C       192.168.1.12/30 is directly connected, Loopback0
R4#sho ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.9       1   FULL/BDR        00:01:35    10.0.0.3        Serial0.1

****************************************************************************
****

Router 5 (spoke):

R5#sho run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
!
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 192.168.1.17 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
!
interface Serial0.1 multipoint
 ip address 10.0.0.5 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
 frame-relay interface-dlci 102
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.16 0.0.0.3 area 0
!
ip classless
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R5#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0.1
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.16 is directly connected, Loopback0
R5#sho ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.9       1   FULL/DR         00:01:36    10.0.0.3        Serial0.1
_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to