As I understand it, iBGP peers will not forward iBGP-learned routes to other
iBGP peers. Because of this behavior, your iBGP peers must be fully meshed.
In your case that means that r2523 should have neighbor statements for both
r2504 *and* r2501 in its BGP config. Likewise, r2501 should peer directly
with r2504 and r2523.
You may be asking yourself "why on earth would this behave this way???"
This seems odd at first but compare BGP to other routing
protocols--especially distance vector protocols--and you'll notice a
difference in the way they try to avoid routing loops.
A router running BGP looks examines the AS-PATH attribute of incoming prefix
advertisements. If it sees its own AS number in the path, it recognizes
that this means there is a loop and it discards the update. This is the BGP
version of the split horizon rule, and here's why it doesn't work in iBGP.
When one BGP peer sends updates to an eBGP peer, it prepends its AS number
to the update. It wouldn't make sense for an iBGP peer to do this when it
forwards updates to other iBGP peers. Therefore, an iBGP peer would never
receive updates from another iBGP with its own AS in the AS-PATH.
If iBGP peers forwarded updates from one iBGP peer to another, routing loops
would develop because they have no way to detect loops. Therefore, iBGP
peers must be fully meshed. This can create some problems as the number of
iBGP peers in your network grows. To ease configuration you have a couple
of options: route reflectors or confederations. These are both methods for
simplifying your iBGP mesh problem. In your case neither of these is
necessary because you only have three iBGP peers.
That was a very long-winded answer and I'm sure it included more information
than you wanted. I also jumped around a lot so forgive me if it
doesn't make a lot of sense!
These are the details as I remember them. Someone please correct me if I've
gotten them wrong.
Regards,
John
| Hey Group,
|
| I'm doing a little BGP lab here in my home, and I'm running into problems
| when trying to get the next-hop-self command to work in between IGP
peers.
| Here's my topology:
|
| r2503 --EBGP-- r2523 --IBGP-- r2504 --IBGP-- r2501
| AS200 AS100 AS100 AS100
|
|
| r2503 has no problem advertising its loopback (1.1.1.1/24) to r2523
through
| their EBGP connection. r2523 then sends the 1.1.1.1/24 route to r2504
while
| changing the next hop to r2523. The problem is that r2504 cannot send the
| 1.1.1.1/24 router to r2501. I assumed that the next-hop-self command
would
| be important in this situation, but it isn't working. Is there anything
that
| I am doing wrong here?
|
|
|
| Here are the configs (without unnecessary info):
|
| hostname r2503
| !
| interface Loopback0
| ip address 1.1.1.1 255.255.255.0
| !
| interface Serial0
| ip address 192.1.1.1 255.255.255.0
| !
| router bgp 100
| network 1.0.0.0
| neighbor 192.1.1.2 remote-as 200
| !
| ----------------------------------------------
| hostname r2523
| !
| interface Loopback0
| ip address 2.2.2.2 255.255.255.0
| !
| interface Serial1
| ip address 192.1.1.2 255.255.255.0
| clockrate 64000
| !
| interface Serial2
| ip address 193.1.1.2 255.255.255.0
| clockrate 64000
| !
| router bgp 200
| network 2.0.0.0
| neighbor 192.1.1.1 remote-as 100
| neighbor 193.1.1.1 remote-as 200
| neighbor 193.1.1.1 next-hop-self
| no synchronization
| --------------------------------------------
| hostname r2504
| !
| interface Loopback0
| ip address 3.3.3.3 255.255.255.0
| !
| interface Serial0
| ip address 193.1.1.1 255.255.255.0
| !
| interface Serial1
| ip address 194.1.1.1 255.255.255.0
| !
| router bgp 200
| no synchronization
| network 3.0.0.0
| neighbor 193.1.1.2 remote-as 200
| neighbor 193.1.1.2 route-reflector-client
| neighbor 193.1.1.2 next-hop-self
| neighbor 194.1.1.2 remote-as 200
| neighbor 194.1.1.2 route-reflector-client
| neighbor 194.1.1.2 next-hop-self
| ------------------------------------------------
| hostname r2501
| !
| interface Loopback0
| ip address 4.4.4.4 255.255.255.0
| no ip directed-broadcast
| !
| interface Serial0
| ip address 194.1.1.2 255.255.255.0
| clockrate 64000
| !
| router bgp 200
| no synchronization
| network 4.0.0.0
| neighbor 194.1.1.1 remote-as 200
|
|
| Thanks in advance,
| Fred
| _________________________________________________________________
| Get your FREE download of MSN Explorer at http://explorer.msn.com
|
|
|
|
| FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
| Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
_______________________________________________________
Send a cool gift with your E-Card
http://www.bluemountain.com/giftcenter/
Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=580&t=568
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]