Hello,
I have very strange problem.

Two routers (client and access-server) are connected via
E1/PRI (using Siemens ISDN switch).

When I simulate short disconnect (several miliseconds) in
access server part and switch doesn't recognize any failure
strange thing occurs. Router recognizes E1 controller down,
all established channels go down and E1 controller goes up.
Everything seems OK, but no traffic go throug this
connection (encapsulation failed in both routers debugs).
When I simulate problem in other side or ISDN switch
recognizes failure, everything is OK.

>From my investigating it seems that the problems is
connected with Balanced module (2CE1B). Module 1FE-2CE-B/U
in unbalanced mode hasn't this problem. However I haven't
both unbalanced modules yet, so I can properly try it.


As for the IOSes, I try a lot of version (12.0.x, 12.0.xT,
12.1.xT etc). The problem is the same.

Is there any possibility, how to prolong down state of E1
controller in situation when it go down? I hope it should
help to recognize failure for ISDN switch.

Thank you any hint.


Michal


Configuration and "sh ver" of one router (access-server):
gcra#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname gcra
!
no logging console
!
username xxxx password 0 xxxx
username xxxx password 0 xxxx
username service password 0 service
ip subnet-zero
no ip domain-lookup
ip address-pool local
isdn switch-type primary-net5
!
!
controller E1 0/0
 pri-group timeslots 1-31
!
controller E1 0/1
!
!
interface Loopback0
 no ip address
 no ip directed-broadcast
!
interface Loopback1
 ip address 192.168.101.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0:15
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type primary-net5
 isdn bchan-number-order ascending
 ppp authentication chap
 ppp multilink
!
interface Ethernet1/0
 ip address 192.168.51.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet1/1
 no ip address
 no ip directed-broadcast
!
interface Dialer1
 description GCRA Generalni reditelstvi CRa, komut.
 ip unnumbered loopback 1
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name stra
 dialer idle-timeout 2147483
 dialer load-threshold 1 either
 dialer max-call 30
 dialer pool 1
 dialer-group 1
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 193.86.0.0 255.255.255.0 Dialer1
!
!
map-class dialer trida1
 dialer idle-timeout 2147483
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end


gcra#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-I-M), Version 12.0(9), RELEASE
SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Wed 26-Jan-00 18:23 by bettyl
Image text-base: 0x60008918, data-base: 0x60680000

ROM: System Bootstrap, Version 11.1(19)AA, EARLY DEPLOYMENT
RELEASE SOFTWARE (fc1)

gcra uptime is 2 hours, 37 minutes
System restarted by power-on
System image file is "flash:c3640-i-mz.120-9.bin"

cisco 3640 (R4700) processor (revision 0x00) with
36864K/12288K bytes of memory.
Processor board ID 03080885
R4700 processor, Implementation 33, Revision 1.0
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
Primary Rate ISDN software, Version 1.1.
2 Ethernet/IEEE 802.3 interface(s)
32 Serial network interface(s)
2 Channelized E1/PRI port(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

gcra#


Configuration and "sh ver" of second router (client)

stra#sh run
Building configuration...

Current configuration : 1249 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname stra
!
no logging console
!
username xxxx password 0 xxxx
!
!
!
!
ip subnet-zero
no ip finger
!
isdn switch-type primary-net5
!
!
controller E1 0/0
!
controller E1 1/0
 pri-group timeslots 1-31
!
controller E1 1/1
!
!
interface FastEthernet1/0
 ip address 193.86.0.241 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0:15
 description Gen. reditelstvi prvnich 30xB
 no ip address
 encapsulation ppp
 ip mroute-cache
 dialer pool-member 12
 isdn switch-type primary-net5
 isdn guard-timer 3000
 isdn bchan-number-order ascending
 fair-queue
 ppp authentication chap
 ppp multilink
!
interface Dialer12
 description GCRA Generalni reditelstvi
 ip address negotiated
 encapsulation ppp
 dialer pool 12
 dialer remote-name gcra
 dialer idle-timeout 2147483
 dialer string 1587 class trida1
 dialer load-threshold 1 either
 dialer-group 1
!
ip classless
ip route 192.168.51.0 255.255.255.0 Dialer12
ip route 192.168.101.0 255.255.255.0 Dialer12
ip http server
!
!
map-class dialer trida1
 dialer idle-timeout 2147483
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

stra#
stra#
stra#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3620-I-M), Version 12.1(7), RELEASE
SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Fri 23-Feb-01 00:03 by kellythw
Image text-base: 0x60008940, data-base: 0x608AE000

ROM: System Bootstrap, Version 11.1(7)AX [kuong (7)AX],
EARLY DEPLOYMENT RELEASE S
OFTWARE (fc2)

stra uptime is 2 hours, 38 minutes
System returned to ROM by power-on
System image file is
"flash:c3620-i-mz.120-7.bin^[[D^[[D^[[D^[[D^[[D^[[1"

cisco 3620 (R4700) processor (revision 0x81) with
47104K/6144K bytes of memory.
Processor board ID 06242493
R4700 CPU at 80Mhz, Implementation 33, Rev 1.0
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
Primary Rate ISDN software, Version 1.1.
1 FastEthernet/IEEE 802.3 interface(s)
31 Serial network interface(s)
3 Channelized E1/PRI port(s)
DRAM configuration is 32 bits wide with parity disabled.
29K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

stra#

Debug, when the problem appears:

first router (access-server):

00:55:22: %CONTROLLER-5-UPDOWN: Controller E1 0/0, changed
state to down
00:55:22: %ISDN-6-LAYER2DOWN: Layer 2 for Interface
Se0/0:15, TEI 0 changed to dow
n
00:55:22: ISDN Se0/0:15: Event: received MNL_RESET_REQ
00:55:22: %ISDN-6-CONNECT: Interface Serial0/0:2 is now
connected to  stra
00:55:22: %ISDN-6-DISCONNECT: Interface Serial0/0:0
disconnected from  stra, call lasted 33 seconds
00:55:22: %LINK-3-UPDOWN: Interface Serial0/0:0, changed
state to down
00:55:22: %DIALER-6-UNBIND: Interface Se0/0:0 unbound from
profile Di1
00:55:22: %ISDN-6-DISCONNECT: Interface Serial0/0:1
disconnected from  stra, call lasted 33 seconds
00:55:22: %LINK-3-UPDOWN: Interface Serial0/0:1, changed
state to down
00:55:22: %DIALER-6-UNBIND: Interface Se0/0:1 unbound from
profile Di1
00:55:22: %ISDN-6-DISCONNECT: Interface Serial0/0:2
disconnected from  stra, call lasted 3 seconds
00:55:22: %LINK-3-UPDOWN: Interface Serial0/0:2, changed
state to down
00:55:22: %DIALER-6-UNBIND: Interface Se0/0:2 unbound from
profile Di1
00:55:22: %DIALER-6-UNBIND: Interface Vi1 unbound from
profile Di1
00:55:22: %LINK-3-UPDOWN: Interface Virtual-Access1, changed
state to down
00:55:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0:0, changed sta
te to down
00:55:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0:1, changed sta
te to down
00:55:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0:2, changed sta
te to down
00:55:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-Access1, changed
 state to down
00:55:24: %CONTROLLER-5-UPDOWN: Controller E1 0/0, changed
state to up
00:55:24: %ISDN-6-LAYER2UP: Layer 2 for Interface Se0/0:15,
TEI 0 changed to up
00:55:49: ISDN Se0/0:15: RX   CALL_PROC pd = 8  callref =
0x8040
00:55:49:         Channel ID i = 0xA98384
00:55:49: ISDN Se0/0:15: TX ->  CONNECT pd = 8  callref =
0x8040
00:55:49:         Channel ID i = 0xA98384
00:55:49: ISDN Se0/0:15: RX  stra
00:56:15: ISDN Se0/0:15: RX   RELEASE_COMP pd = 8  callref
= 0x803D
00:56:15:         Cause i = 0x80D1 - Invalid call reference
value
00:56:15: ISDN Se0/0:15: RX   RELEASE_COMP pd = 8  callref
= 0x803E
00:56:15:         Cause i = 0x80D1 - Invalid call reference
value
00:56:15: ISDN Se0/0:15: RX   RELEASE_COMP pd = 8  callref
= 0x803F
00:56:15:         Cause i = 0x80D1 - Invalid call reference
value
00:56:19: ISDN Se0/0:15: RX  stra
00:56:19: ISDN Se0/0:15: TX ->  CALL_PROC pd = 8  callref =
0x8041
00:56:19:         Channel ID i = 0xA98381
00:56:19: ISDN Se0/0:15: TX ->  CONNECT pd = 8  callref =
0x8041
00:56:19:         Channel ID i = 0xA98381
00:56:19: ISDN Se0/0:15: RX  stra
gcra#conf t
Enter configuration commands, one per line.  End with
CNTL/Z.
gcra(config)#
00:56:49: ISDN Se0/0:15: RX  stra
00:56:49: ISDN Se0/0:15: TX ->  CALL_PROC pd = 8  callref =
0x8042
00:56:49:         Channel ID i = 0xA98382
00:56:49: ISDN Se0/0:15: TX ->  CONNECT pd = 8  callref =
0x8042
00:56:49:         Channel ID i = 0xA98382
00:56:49: ISDN Se0/0:15: RX   CONNECT_ACK pd = 8  callref
= 0x0040
00:55:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0:3, changed s
tate to up
00:55:39: %ISDN-6-CONNECT: Interface Serial1/0:3 is now
connected to 1587 gcra
00:55:59: %DIALER-6-UNBIND: Interface Se1/0:0 unbound from
profile Di12
00:55:59: %ISDN-6-DISCONNECT: Interface Serial1/0:0
disconnected from 1587 gcra
, call lasted 86 seconds
00:55:59: ISDN Se1/0:15: TX ->  DISCONNECT pd = 8  callref =
0x003D
00:55:59:         Cause i = 0x8090 - Normal call clearing
00:55:59: %DIALER-6-UNBIND: Interface Se1/0:1 unbound from
profile Di12
00:55:59: %ISDN-6-DISCONNECT: Interface Serial1/0:1
disconnected from 1587 gcra
, call lasted 86 seconds
00:55:59: ISDN Se1/0:15: TX ->  DISCONNECT pd = 8  callref =
0x003E
00:55:59:         Cause i = 0x8090 - Normal call clearing
00:55:59: %DIALER-6-UNBIND: Interface Se1/0:2 unbound from
profile Di12
00:55:59: %ISDN-6-DISCONNECT: Interface Serial1/0:2
disconnected from 1587 gcra
, call lasted 56 seconds
00:55:59: ISDN Se1/0:15: TX ->  DISCONNECT pd = 8  callref =
0x003F
00:55:59:         Cause i = 0x8090 - Normal call clearing
00:56:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0:0, changed s
tate to down
00:56:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0:1, changed s
tate to down
00:56:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0:2, changed s
tate to down
00:56:03: ISDN Se1/0:15: TX ->  SETUP pd = 8  callref =
0x0041
00:56:03:         Bearer Capability i = 0x8890
00:56:03:         Channel ID i = 0xA98385
00:56:03:         Called Party Number i = 0x81, '1587',
Plan:ISDN, Type:Unknown
00:56:03: ISDN Se1/0:15: RX   CONNECT_ACK pd = 8  callref
= 0x0041
00:56:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0:4, changed s
tate to up
00:56:09: %ISDN-6-CONNECT: Interface Serial1/0:4 is now
connected to 1587 gcra
00:56:29: ISDN Se1/0:15: TX ->  RELEASE pd = 8  callref =
0x003D
00:56:29:         Cause i = 0x8090 - Normal call clearing
00:56:29: ISDN Se1/0:15: TX ->  RELEASE pd = 8  callref =
0x003E
00:56:29:         Cause i = 0x8090 - Normal call clearing
00:56:29: ISDN Se1/0:15: RX   RELEASE pd = 8  callref =
0x003F
00:56:29:         Cause i = 0x8090 - Normal call clearing
00:56:29: ISDN Se1/0:15: RX   SETUP pd = 8  callref =
0x0042
00:56:33:         Bearer Capability i = 0x8890
00:56:33:         Channel ID i = 0xA98381
00:56:33:         Called Party Number i = 0x81, '1587',
Plan:ISDN, Type:Unknown
00:56:33: ISDN Se1/0:15: RX   CONNECT_ACK pd = 8  callref
= 0x0042
00:56:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0:0, changed s
tate to up
00:56:39: %ISDN-6-CONNECT: Interface Serial1/0:0 is now
connected to 1587 gcra
stra#conf t
Enter configuration commands, one per line.  End with
CNTL/Z.
stra(config)#no logg con
stra(config)#




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=4273&t=4273
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to