Hi,
    I have the following testing bgp configuration and try to use
route-map with regular expression to filter AS300 out but not
successful. Pls advise what will be correct regular expression if I
would like to block only AS300(172.3.0.0) to R1.

R1(AS100)-->R2(AS200)--->R3(AS300)--->R4(AS400)
Below is the R1 configuration and show ip bgp
Current configuration : 986 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable secret 5 $1$Jkuc$VkhuVvbEL1129unNyEzaZ1
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 172.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 172.1.2.1 255.255.255.0
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Serial0/0
 ip address 10.1.1.1 255.255.255.0
 no ip mroute-cache
 no fair-queue
!
router bgp 100
 bgp log-neighbor-changes
 network 172.1.2.0 mask 255.255.255.0
 timers bgp 10 10
 neighbor 172.2.1.1 remote-as 200
 neighbor 172.2.1.1 ebgp-multihop 255
 neighbor 172.2.1.1 update-source Loopback0
 neighbor 172.2.1.1 route-map doit in
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.2
no ip http server
ip as-path access-list 1 permit ^200
ip as-path access-list 1 permit ^400
!
route-map doit permit 10
 match as-path 1
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

r1#show ip bgp
BGP table version is 5, local router ID is 172.1.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 172.1.2.0/24     0.0.0.0                  0         32768 i
*> 172.2.2.0/24     172.2.1.1              0             0 200 i
*> 172.3.2.0/24     172.2.1.1                           0 200 300 i
*> 172.4.2.0/24     172.2.1.1                              0 200 300 400
i
r1#




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=18382&t=18382
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to