I'd like to hazard a guess here.

My guess is that termsrv is passing 24.0.0.0/8 as the default network,
yet rta does not have this in its routing tables.  If you add a static
route for 24.0.0.0/8 to Null0 on termsrv, eigrp will pass this route to
rta, allowing rta to make that the default network.

This is a good one!  Am I close?

John

>>> "EA Louie"  9/7/01 4:53:19 AM >>>
While studying Doyle Vol 1 p. 755-758 (default-network), I made an
interesting yet painful discovery (besides the typo on p 755).  Simple
scenario: Two routers connected via serial interfaces and the default
network on the Ethernet interface of termsrv.  I was trying to get the
candidate default route to advertise to rtra, but it wouldn't work
until I
made one config change.

Can you figure out where, and what that change was?  Bonus "points" if
you
can tell me why.

Hint:  It surprised me because it's an almost automatic command that I
type
in when I configure that particular feature.  It showed up when I did
a
debug ip eigrp on rtra

Here are the configs and routing tables with the unneeded portions
snipped:

******** termsrv *********

hostname termsrv
!
ip subnet-zero
!
interface Ethernet0
 ip address 24.21.8.200 255.255.255.192
 no ip directed-broadcast
!
interface Serial0
 ip address 192.168.2.2 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
router eigrp 1
 network 24.0.0.0
 network 192.168.2.0
 no auto-summary
!
ip classless
ip default-network 24.0.0.0
!

********* rtra *********

hostname rtra
!
ip subnet-zero
!
interface Serial0
 ip address 192.168.2.1 255.255.255.252
 no fair-queue
 clockrate 4000000
!
router eigrp 1
 network 172.16.0.0
 network 192.168.2.0
 no auto-summary
!
ip classless

******** routing tables termsrv *******
termsrv#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
C    172.17.0.0/16 is directly connected, Loopback11
     172.16.0.0/24 is subnetted, 3 subnets
D       172.16.4.0 [90/2185984] via 192.168.2.1, 00:09:53, Serial0
D       172.16.5.0 [90/2297856] via 192.168.2.1, 00:09:53, Serial0
C       172.16.1.0 is directly connected, Loopback10
 *   24.0.0.0/26 is subnetted, 1 subnets
C       24.21.8.192 is directly connected, Ethernet0
     192.168.2.0/30 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Serial0
termsrv#

******** routing table rtra ********
rtra#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.4.0 is directly connected, TokenRing0
C       172.16.5.0 is directly connected, Loopback0
     24.0.0.0/26 is subnetted, 1 subnets
D       24.21.8.192 [90/3097600] via 192.168.2.2, 00:10:44, Serial0
     192.168.2.0/30 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Serial0
rtra#


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=18986&t=18941
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to