You are in luck, sort of. In one of our previous tirades ;-) about DHCP, I 
sent the following message, which includes a DHCP Discover relayed by a 
router near the end. I can't send you the trace file, however, because it 
has some confidential stuff in it.


Here's my config. The client is on the 36.1.1.0 network.

I was sitting with my EtherPeek protocol analyzer on the 10.10.0.0 network.
I could see the DHCP Discover come through to 10.10.0.1 as long as I used 
"ip helper-address 10.10.0.1."

charlotte#s run
Building configuration...

Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname charlotte
!
enable password xxxx
!
interface Ethernet0
   ip address 10.10.0.2 255.255.255.0
!
interface Ethernet1
   ip address 36.1.1.1 255.255.255.0
   ip helper-address 10.10.0.1
!
interface Serial0
   ip address 192.168.40.2 255.255.255.0
   no fair-queue
!
interface Serial1
   no ip address
   shutdown
!
interface TokenRing1
   no ip address
   shutdown
!
interface TokenRing0
   no ip address
   shutdown
!
router ospf 100
   network 192.168.0.0 0.0.255.255 area 2
   network 10.10.0.0 0.0.255.255 area 0
   network 36.1.1.0 0.0.0.255 area 2
!
line con 0
line aux 0
   transport input all
line vty 0 4
   password cisco
   login
!
end


The DHCP Discover from the client that I captured might be informative for
people learning about how DHCP Relay works. Notice that the packet is a
unicast, rather than a broadcast. Also, notice at the IP layer that the
source address is the router, not the client's 0.0.0.0 address that you
normally see with DHCP. The router also put its address in the DHCP server
under "Gateway IP Address." The DHCP server needs to see this to know which
subnet the client's request came from.

Ethernet Header
    Destination:  00:00:0C:05:3E:80
    Source:       00:00:0C:00:2E:75
    Protocol Type:0x0800  IP
IP Header - Internet Protocol Datagram
    Version:              4
    Header Length:        5  (20  bytes)
    Type of Service:      %00000000
    Precedence: Routine,   Normal Delay,   Normal Throughput,   Normal
Reliability
    Total Length:         328
    Identifier:           12800
    Fragmentation Flags:  %000  May Fragment   Last Fragment
    Fragment Offset:      0  (0  bytes)
    Time To Live:         127
    Protocol:             17  UDP
    Header Checksum:      0xD998
    Source IP Address:    36.1.1.1
    Dest. IP Address:     10.10.0.1
    No IP Options
UDP - User Datagram Protocol
    Source Port:          68  Bootstrap (BOOTP Client)
    Destination Port:     67  Bootstrap Protocol Server
    Length:               308
    Checksum:             0x3159
BootP - Bootstrap Protocol
    Operation:                    1  Boot Request
    Hardware Address Type:        1  Ethernet (10Mb)
    Hardware Address Length:      6  bytes
    Hops:                         0
    Transaction ID:               678970121
    Seconds Since Boot Start:     0
    Flags:                        0x0000
    IP Address Known By Client:   0.0.0.0  IP Address Not Known By Client
    Client IP Addr Given By Srvr: 0.0.0.0
    Server IP Address:            0.0.0.0
    Gateway IP Address:           36.1.1.1
    Client Hardware Address:      00:E0:98:89:52:FA
    Unused:                       0x00000000000000000000
    Server Host Name:
    ................  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    Boot File Name:
    ................  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
DHCP - Dynamic Host Configuration Protocol
    DHCP Magic Cookie:            0x63825363
    Message TypeDHCP Option
      Option Code:        53  Message Type
      Option Length:      1
      Message Type:       1  Discover
    Client IdentifierDHCP Option
      Option Code:        61  Client Identifier
      Option Length:      7
      Hardware Type:      1
      Hardware Address:   00:E0:98:89:52:FA
    Requested IP AddressDHCP Option
      Option Code:        50  Requested IP Address
      Option Length:      4
      Address:            36.1.1.2
    Host Name AddressDHCP Option
      Option Code:        12  Host Name Address
      Option Length:      8
      String:             MACTEAM.
    Vendor Class IdentifierDHCP Option
      Option Code:        60  Vendor Class Identifier
      Option Length:      7
      Option Data:
    MSFT 98           4D 53 46 54 20 39 38
    Parameter Request ListDHCP Option
      Option Code:        55  Parameter Request List
      Option Length:      9
      Requested Option:   1  Subnet Mask
      Requested Option:   15  Domain Name
      Requested Option:   3  Routers
      Requested Option:   6  Domain Name Servers
      Requested Option:   44  NetBIOS (TCP/IP) Name Servers
      Requested Option:   46  NetBIOS (TCP/IP) Node Type
      Requested Option:   47  NetBIOS (TCP/IP) Scope
      Requested Option:   43  Vendor Specific Information
      Requested Option:   77  User Class Information
    DHCP Option End
      Option Code:        255  End
Extra bytes (Padding):
    ...........       00 00 00 00 00 00 00 00 00 00 00
Frame Check Sequence:  0x00000000


Priscilla


At 05:44 PM 10/5/01, Lists Wizard wrote:
>Hi Group,
>
>I am interested in the details (at the packet level) of DHCP communication
>between the client and a DHCP server when there is a router in the middle.
>Can any body provide me with sniffer trace of this kind of communication? I
>use SnifferPro.
>
>Thanks
>
>Lists Wizard
________________________

Priscilla Oppenheimer
http://www.priscilla.com




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=22292&t=22272
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to