Ben,
I could be wrong, and you're using a new angle I've never seen before on
implementing NAT,
But I think your problem is this:

You need to specify a NAT Pool, and the Access-List 152 is applied to that
pool, rather than what you're trying to do.

This is what I mean.

ip nat pool Name-of-Pool 216.162.122.Y 216.162.122.Z netmask 255.255.255.248
ip nat inside source list 152 pool Name-of-Pool overload

Note: Y and Z are Start and End of IP block, chosen by your preference if
you want to also use statics out of your block.

This may be why you are not getting return traffic.  NAT is broken.

-Mark Odette II
StellarConnection Services
-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Ben Hockenhull
Sent: Friday, October 19, 2001 11:44 AM
To: [EMAIL PROTECTED]
Subject: ADSL/BVI problems [7:23535]


I finally got it through my thick head that it was a *bridged* connection,
and set up IRB.

Sure enough, I was then able to ping the next hop address with packets
sourced from the public IP I was given.  However, I seem to be unable to
hit anything outside that particular subnet, and I'm not sure why.  If I
try and ping www.yahoo.com, for instance, I get no response.  This is true
if I ping from the internal network (and thus NAT) or if I ping sourced
from the BVI interface (avoiding NAT).

It all works fine if I use the external ADSL bridge.  Ideas?

Relevant config:

!
!
bridge irb
!
!
!
!
interface ATM0/0
 mtu 1500
 no ip address
 atm vc-per-vp 256
 no atm auto-configuration
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
 pvc valuenet 0/35
  encapsulation aal5snap
 !
 bridge-group 1
!
interface FastEthernet0/0
 description Internal Network
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 speed 100
 full-duplex
!
interface BVI1
 ip address 216.162.122.26 255.255.255.248
 ip nat outside
!
ip nat inside source list 152 interface BVI1 overload
!
ip classless
ip route 0.0.0.0 0.0.0.0 BVI1
!
access-list 152 permit ip 192.168.10.0 0.0.0.255 any
!
bridge 1 protocol ieee
 bridge 1 route ip

ATM0/0 is up, line protocol is up
  Hardware is DSLSAR (with Alcatel ADSL Module)
  MTU 1500 bytes, sub MTU 1500, BW 160 Kbit, DLY 12800 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5 AAL2, PVC mode
  23 maximum active VCs, 256 VCs per VP, 1 current VCCs
  VC idle disconnect time: 300 seconds
  Last input 00:05:08, output 00:00:01, output hang never
  Last clearing of "show interface" counters 00:07:49
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: None
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     10 packets input, 1102 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     291 packets output, 14241 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
ATM0/0.1 is up, line protocol is up
  Hardware is DSLSAR (with Alcatel ADSL Module)
  MTU 1500 bytes, BW 160 Kbit, DLY 12800 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM
  5 packets input, 586 bytes
  277 packets output,13639 bytes
  0 OAM cells input, 0 OAM cells output

BVI1 is up, line protocol is up
  Hardware is BVI, address is 0000.0cfa.4c54 (bia 0000.0000.0000)
  Internet address is 216.162.122.26/29
  MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/0, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     136 packets output, 8592 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=23551&t=23535
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to