Is it me or does BGP not allow you to form a peering session unless you have
a route to the host in the routing table, no matter what.  It closes
connected sessions even if I have policy route data forwarding configured
and even if traffic is forwarding correctly.  Is there some knob I'm
forgetting about (other than using a static classful route to null0)?
 
My little diagram...
                          
                178.24.1.1/32             204.22.10.1/32
                          Lo                         Lo
                           |                            |
                        R6                           R7
                          
                           |                            |
                         S0  S0
  192.1.1/24       (.3)                          (.1)
 
a.      No static routes entered on R6 or R7
b.      BGP peers w/ loopback addresses
 
 
Here's 11.3 (R7) forgetting that it can reach the 12.0 router via policy
(debug output on R7)
3d05h: BGP: 178.24.1.1 remote close, state CLOSEWAIT
3d05h: BGP: 178.24.1.1 closing
 
(This message repeated indefinitely)
3d05h: BGP: 178.24.1.1 multihop open delayed 10112ms (no route)
3d05h: BGP: 178.24.1.1 multihop open delayed 12784ms (no route)
 
(traffic is forwarding!)
r7#ping 178.24.1.1
Sending 5, 100-byte ICMP Echos to 178.24.1.1, timeout is 2 seconds:
!!!!!
 
r7#config t
r7(config)#ip route 178.24.1.1 255.255.255.255 192.1.1.3[Ctl-Z]
 
[a few seconds later]
(debug output on R7)
3d05h: BGP: 178.24.1.1 open active, local address 204.22.10.1
 
r7#config t
r7(config)#no ip route 178.24.1.1 255.255.255.255 192.1.1.3[Ctl-Z]
 
[a few seconds later]
(debug output on R7)
3d07h: BGP: 178.24.1.1 multihop open delayed 17648ms (no route)
 
grrr.....
 
(configs below)
 
 
Thanks for looking this over.
 
WAYNE BAETY, MCSE, A1C, USAF
Network Systems Trainer
 
 
ROUTER 6 CONFIG----------------------------------------------------
 
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
logging buffered warnings
logging console warnings
enable password cisco
!
username cisco password 0 cisco
!
!
!
!
ip subnet-zero
!
!
!
process-max-time 200
!
interface Loopback0
 ip address 178.24.1.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.0.0.6 255.255.255.0 secondary
 ip address 6.6.6.6 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 clockrate 250000
 cdp enable
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 ip address 10.255.1.2 255.255.255.252
 no ip directed-broadcast
 ip nat inside
 frame-relay interface-dlci 601
!
interface Serial0.2 point-to-point
 ip address 192.1.1.3 255.255.255.0
 no ip directed-broadcast
 ip nat outside
 ip policy route-map ebgp-rehop
 frame-relay interface-dlci 607
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router bgp 300
 network 178.24.0.0
 neighbor 204.22.10.1 remote-as 100
 neighbor 204.22.10.1 ebgp-multihop 2
 neighbor 204.22.10.1 update-source Loopback0
!
ip local policy route-map ebgp-rehop
ip nat pool dynamic-net-pool 178.24.16.1 178.24.191.254 prefix-length 16
ip nat inside source list 1 pool dynamic-net-pool
ip nat inside source static 178.24.3.13 10.253.1.1
ip classless
no ip http server
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 101 permit tcp any host 204.22.10.1 eq bgp
access-list 101 permit icmp any host 204.22.10.1 echo
access-list 101 permit icmp any host 204.22.10.1 echo-reply
route-map ebgp-rehop permit 10
 match ip address 101
 set ip default next-hop 192.1.1.1
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 monitor
 
----------------------------------------------------END ROUTER 6 CONFIG
 
ROUTER 7 CONFIG ----------------------------------------------------
 
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
enable password cisco
!
username cisco password 0 cisco
ip subnet-zero
ip nat pool dynamic-net-pool 204.22.10.16 204.22.10.191 prefix-length 24
ip nat inside source list 1 pool dynamic-net-pool
ip nat inside source static 204.22.10.13 20.255.1.5
!
!
interface Loopback0
 ip address 204.22.10.1 255.255.255.255
!
interface Ethernet0
 ip address 10.0.0.7 255.255.255.0 secondary
 ip address 7.7.7.7 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 clockrate 250000
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 ip address 20.255.1.2 255.255.255.252
 ip nat inside
 no arp frame-relay
 frame-relay interface-dlci 705
!
interface Serial0.2 point-to-point
 ip address 192.1.1.1 255.255.255.0
 ip nat outside
frame-relay interface-dlci 706
!
interface Serial1
 no ip address
 shutdown
!
router bgp 100
 network 204.22.10.0
 neighbor 178.24.1.1 remote-as 300
 neighbor 178.24.1.1 ebgp-multihop 2
 neighbor 178.24.1.1 update-source Loopback0
!
ip local policy route-map ebgp-rehop
ip classless
ip route 178.24.1.1 255.255.255.255 192.1.1.3
!
logging buffered warnings
logging console warnings
access-list 1 permit 20.0.0.0 0.255.255.255
access-list 101 permit tcp any host 178.24.1.1 eq bgp
access-list 101 permit icmp any host 178.24.1.1 echo
access-list 101 permit icmp any host 178.24.1.1 echo-reply
route-map ebgp-rehop permit 10
 match ip address 101
 set ip default next-hop 192.1.1.3
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 monitor




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=27976&t=27976
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to