I spent a bit more time looking into this one than it may be worth. But my
look did reinforce some points made in this thread and in another thread
started by John Neiberger and researched so ably by Nigel Taylor - that is,
the nature and behaviour of secondary addresses.

Sorry I am unable to document everything I did here. It would take me
writing a Jeff Doyle type chapter on RIP to get it all out and explained,
with screen shots etc.

To put things in terms of how I observed them:

In the case of RIP, by default, advertisements are sent out an interface
using  the primary address of that interface as the source address.

if another router on the segment is using and address that is not on the
same subnet as the primary, that router will see messages like this:

01:46:25: RIP: ignored v1 update from bad source 172.29.101.1 on TokenRing0
01:46:30: RIP: ignored v1 update from bad source 172.29.101.2 on TokenRing0
01:46:35: RIP: sending v1 update to 255.255.255.255 via TokenRing0
(172.29.103.7)

103.1 was secondary address on my R1, 103.7 the address of my R3 You can see
the error referring to 101.1 and 102.1 ( the address of another router on
the segment )

I threw in a no ip split-horizon command on the interface of my R1, and lo
and behold, it started sourcing rip packets from 101.1, 102.1 and 103.1 and
all my RIP routes propagated

from CCO:

Note   If any router on a network segment uses a secondary address, all
other routers on that same segment must also use a secondary address from
the same network or subnet.


some of us already commented about issues with secondary routes among the
various routing protocols. the point being that using secondary addresses
can be tricky, and is probably not a good idea for newbies just trying to
learn the basics. if you want to see how things work, use loopbacks. with
secondary addresses, it is to easy to end up fighting with some complex
issues beyond a beginner's understanding. in fact, there are some advanced
students who find this topic complex and mysterious.

best wishes.

Chuck

BTW, one of the implications of this study was a walk down memory lance. A
guy named Bob Vance who used to hang here a lot and who was the progenitor
of a number of interesting discussions once postulated that all stations on
a segment will see the all F's broadcast, even if their layer three
addresses are different ( i.e. seconday's ) the output above is something of
a proof of that supposition. The router saw the RIP packets with the
destination address of 255.255.255.255 ( MAC FFFF.FFFF.FFFF ), processed the
packet, saw the source address as being on a different subnet ( even though
on the same segment ) and rejected the packet. Interesting. Especially in
that all subnets were part of the same Class B network.




-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Logan, Harold
Sent: Friday, December 07, 2001 6:21 AM
To: [EMAIL PROTECTED]
Subject: RE: RIP routing (2 router lab) newbie [7:28327]


It looks like Anil wants to get RIP to advertise the 193.9.200.0
network. A secondary address may work on one of the interfaces, but it
would need to be on a different subnet. Notice from the config, he gave
the secondary address the same IP as the primary addy. No matter what he
does with the 193.9.200.0 network, those two routers will always show it
as being "Directly Connected" instead of learned through RIP; DC routes
have an administrative distance of 0, whereas RIP has an AD of 120. In
the routing table, the router is only going o show the route with the
best (lowest) distance. He could add a loopback on a different subnet on
one of the routers, then add network statements for that subnet, and
then he would see that network learned via RIP on the opposite router.
Likewise Anil, if you had a 3rd router connecting to one of your two
routers by the BRI port, that 3rd router would learn of the 193.9.200.0
network through RIP. (Granted, RIP wouldn't be your ideal routing
protocol for an ISDN line, but that's going a little bit deeper than you
need to for now)

Try these configs, then look at your routing tables:

> hostname rustya
> !
> enable secret 5 $1$Ws8V$mRIwI97bc/Iv7PAEKFBVo1
> !
> interface Loopback0
>  ip address 200.10.10.1 255.255.255.0
> !
> interface Ethernet0
>  ip address 192.9.200.1 255.255.255.0
> !
> interface BRI0
>  no ip address
>  shutdown
> !
> router rip
>  network 193.9.200.0
>  network 200.10.10.0
> !
> no ip classless
> !
> line con 0
> line vty 0 4
>  password cisco
>  login
> !
> end


> hostname rustyb
> !
> enable secret 5 $1$JycL$W4sNa8kuL2.tppX2IYQJU/
> !
> interface Loopback0
>  ip address 201.10.10.1 255.255.255.0
> !
> interface Ethernet0
>  ip address 192.9.200.2 255.255.255.0
> !
> interface BRI0
>  no ip address
>  shutdown
> !
> router rip
>  network 196.9.200.0
>  network 201.10.10.0
> !
> no ip classless
> !
> line con 0
> line vty 0 4
>  password cisco
>  login
> !
> end

hth,
Hal


> -----Original Message-----
> From: Kane, Christopher A. [mailto:[EMAIL PROTECTED]]
> Sent: Thursday, December 06, 2001 9:26 PM
> To: [EMAIL PROTECTED]
> Subject: RE: RIP routing (2 router lab) newbie [7:28327]
>
>
> I'm not sure if RIP is the same as OSPF, but if so, you must have OSPF
> running on the interface via the Primary address in order to have the
> Secondary address also participate in OSPF. Did you try
> adding your Primary
> address (network statement) to RIP also?
>
> Chris
>
>
>
> -----Original Message-----
> From: Chuck Larrieu
> To: [EMAIL PROTECTED]
> Sent: 12/6/01 5:45 PM
> Subject: RE: RIP  routing (2 router lab) newbie [7:28327]
>
> try using loopbacks instead of secondaries. Are your
> secondary addresses
> part of the RIP process via network statements? same subnet
> boundary as
> the
> primary address?
>
> Chuck
>
> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
> anil
> Sent: Thursday, December 06, 2001 2:03 PM
> To: [EMAIL PROTECTED]
> Subject: RIP routing (2 router lab) newbie [7:28327]
>
>
> 2 C1603's connected to a hub.
> It should be simple but I cannot see why RIP does not
> update the routing tables (in either direction).
> I added secondary addresses to both routers e0, and want RIP to send
> these
> routes.
>
> Any comments/suggestions welcome.
> Many thanks
> -Anil
>
>
> ---------
> rustya#sh ip route
>
> Gateway of last resort is not set
> C    193.9.200.0/24 is directly connected, Ethernet0
> C    192.9.200.0/24 is directly connected, Ethernet0
> rustya#
> ------------------------------
> hostname rustya
> !
> enable secret 5 $1$Ws8V$mRIwI97bc/Iv7PAEKFBVo1
> !
> !
> interface Ethernet0
>  ip address 193.9.200.1 255.255.255.0 secondary
>  ip address 192.9.200.1 255.255.255.0
> !
> interface BRI0
>  no ip address
>  shutdown
> !
> router rip
>  network 193.9.200.0
> !
> no ip classless
> !
> line con 0
> line vty 0 4
>  password cisco
>  login
> !
> end
>
>
>
> --------------------------------
> rustyb#sh ip route
>
> Gateway of last resort is not set
>
> C    192.9.200.0/24 is directly connected, Ethernet0
> C    196.9.200.0/24 is directly connected, Ethernet0
> rustyb#
> --------------------------------
> hostname rustyb
> !
> enable secret 5 $1$JycL$W4sNa8kuL2.tppX2IYQJU/
> !
> !
> interface Ethernet0
>  ip address 196.9.200.1 255.255.255.0 secondary
>  ip address 192.9.200.2 255.255.255.0
> !
> interface BRI0
>  no ip address
>  shutdown
> !
> router rip
>  network 196.9.200.0
> !
> no ip classless
> !
> line con 0
> line vty 0 4
>  password cisco
>  login
> !
> end




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=28632&t=28327
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to