Tom,

I have config'd my Lab and it works:
Your router 9.9.9.9 is my rtrB:
rtrB#sh ip bgp 100.0.0.0
BGP routing table entry for 100.0.0.0/24, version 2
Paths: (1 available, best #1)
  Advertised to non peer-group peers:
    10.0.0.33    best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i100.0.0.0/24     10.0.0.37                0    100      0 i
*> 100.0.1.0/24     0.0.0.0                  0         32768 i


My rtrC is the AS 100 router. Below, you can see that he's learning 2
prefixes from both routers in AS 400. By looking at the ">" you can see
which route he's putting in his routing table. This is based on the MEDS
that rtrA (your 6.6.6.6) and rtrB (your 9.9.9.9) are sending him.
See below:

rtrC#sh ip bgp n 10.0.0.18 rou
BGP table version is 16, local router ID is 10.0.0.17
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     10.0.0.18                5             0 400 i
*  100.0.1.0/24     10.0.0.18               10             0 400 i

Total number of prefixes 2
rtrC#sh ip bgp n 10.0.0.34 rou
BGP table version is 16, local router ID is 10.0.0.17
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  100.0.0.0/24     10.0.0.34               10             0 400 i
*> 100.0.1.0/24     10.0.0.34                5             0 400 i

Total number of prefixes 2





My configs are the same as yours with the exception of the route-map name.
My route-map name matches the route map that I am calling in my nei
statement to 10.0.0.33 on rtrB (9.9.9.9).

HTH,
Chris


-----Original Message-----
From: Tom Pruneau [mailto:[EMAIL PROTECTED]]
Sent: Thursday, January 10, 2002 8:33 AM
To: [EMAIL PROTECTED]
Subject: Help Please! BGP question, why do I get "Not advertised to any
[7:31528]


BGP question, why do I get "Not advertised to any peer"


Below is from an isolated lab configuration, appologies to the actual
owners of any addresses of AS numbers used.



I have two routers connected together via a serial line. They are in AS400.
They are both connected to AS100 via another serial line. Both have a route
map affecting advertisements to AS100.  They each have an ethernet with a
/24 on it. The /24 is getting into BGP via a network command.

The two routers have the loopbacks 6.6.6.6 and 9.9.9.9

network 100.0.0.0 /24 is connected to the ethernet of router 6.6.6.6
network 100.0.1.0 /24 is connected to the ethernet of router 9.9.9.9

When I am on router 6.6.6.6 and I look at the advertisement of network
100.0.1.0 /24 is looks fine
When i am on router 9.9.9.9 and I look at the advertisement of network
100.0.0.0 /24 it says "Not advertised to any peer"

Any ideas why the difference???? Why can't 100.0.0.0 be avertised to any
peer?

Both routers have been rebooted. The configs look almost identical.


router_6666#sho ip bgp 100.0.1.0
BGP routing table entry for 100.0.1.0/24, version 2
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to non peer-group peers:     <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
  10.0.0.17
  Local
    10.0.0.38 from 10.0.0.38 (9.9.9.9)
      Origin IGP, metric 0, localpref 100, valid, internal, best



router_9999#show ip bgp 100.0.0.0
BGP routing table entry for 100.0.0.0/24, version 9
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer  <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
  Local
    10.0.0.37 from 10.0.0.37 (6.6.6.6)
      Origin IGP, metric 0, localpref 100, valid, internal, best




router 6666

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Ethernet0
 ip address 100.0.0.1 255.255.255.0
!
interface Serial0
 ip address 10.0.0.18 255.255.255.252
!
interface Serial1
 ip address 10.0.0.37 255.255.255.252
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 100.0.0.0 mask 255.255.255.0
 neighbor 10.0.0.17 remote-as 100
 neighbor 10.0.0.17 route-map set_meds out
 neighbor 10.0.0.38 remote-as 400
 no auto-summary
!
ip classless
ip route 9.9.9.9 255.255.255.255 10.0.0.38
no ip http server
!
access-list 20 permit 100.0.0.0
access-list 21 permit 100.0.1.0
route-map set_meds permit 10
 match ip address 20
 set metric 5
!
route-map set_meds permit 20
 match ip address 21
 set metric 10


Router 9999

!
interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface Ethernet0
 ip address 100.0.1.1 255.255.255.0
!
interface Ethernet1
 no ip address
!
interface Serial0
 ip address 10.0.0.38 255.255.255.252
 no fair-queue
 clockrate 2000000
!
interface Serial1
 ip address 10.0.0.34 255.255.255.252
 clockrate 2000000
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 100.0.1.0 mask 255.255.255.0
 neighbor 10.0.0.33 remote-as 100
 neighbor 10.0.0.33 route-map set_meds out
 neighbor 10.0.0.37 remote-as 400
 no auto-summary
!
ip classless
ip route 6.6.6.6 255.255.255.255 10.0.0.37
no ip http server
!
access-list 20 permit 100.0.0.0
access-list 21 permit 100.0.1.0
route-map set_med permit 10
 match ip address 21
 set metric 5
!
route-map set_med permit 20
 match ip address 20
 set metric 10
Tom Pruneau 
Technical Trainer Network Operations
GENUITY
225 Presidential Way Woburn Ma. 01888
---------------------------------------------------------------------------
This email is composed of 82% post consumer recycled data bits
---------------------------------------------------------------------------
"Once in a while you get shown the light in the strangest of places if you
look at it right"




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31571&t=31571
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to