I was working with FR in my home lab, and I ran into an interesting
problem.  This is the first time I've set up a router to function as a FR
switch.  Here's the scenario.

I am using a 2524 with two five-in-one serial modules as the FR switch to
connect two routers with fixed serial ports, a 2503 and a 2509.  The PVC is
up and active.  I can ping from each router, through the FR switch to the
router on the other side, but I cannot internally ping the FR interface of
the router I am pinging from.  After checking around a bit, I learned that
pinging a serial interface of the router originating the ping works
differently than pinging an ethernet interface.  Apperently, serial
interfaces cannot responded internally to an interally generated ping -- the
ping actually goes out on the wire and comes back.  I don't completely
understand this, but it is clear the the ping does travel through the
external cable.

So can anyone tell me why the internal ping to the FR interface doesn't
work.  It isn't a big deal, but I would like to understand what is going
on.  Is there a problem with the way I have configured the 2524 as a FR
switch?

Here are the configurations.

START OF CONFIGURATION FOR CISCO 2524 ACTINT AS A FRAME RELAY SWITCH.  2524
EQUIPPED WITH TWO FIVE-IN-ONE SERIAL MODULES.

frameswitch#show run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname frameswitch
!
!
ip subnet-zero
frame-relay switching
!
!
!
interface Ethernet0
 ip address 192.168.1.105 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 clockrate 56000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial1 901
!
interface Serial1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 clockrate 56000
 frame-relay intf-type dce
 frame-relay route 901 interface Serial0 301
!
ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

START OF CONFIGURATION OF CISCO 2503 CONNECTED TO CISCO 2509 VIA CISCO 2524
ACTING AS A FRAME RELAY SWITCH

2503A#show run
Building configuration...

Current configuration:
!
version 11.0
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2503A
!
enable secret 5 $1$n6HI$CliSp0vBx8d8fUPVllPON.
enable password 7 140713181F13253920
!
!
interface Loopback0
 ip address 172.16.18.1 255.255.255.0
!
interface Ethernet0
 ip address 192.168.1.106 255.255.255.0
!
interface Serial0
 ip address 172.16.17.1 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay map ip 172.16.17.2 301 broadcast
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
!
line con 0
 password 7 15190A1E08
 login
line aux 0
 password 7 15190A1E08
 login
 transport input all
line vty 0 4
 password 7 110218171B
 login
!
end

START OF CONFIGURATION OF CISCO 2509 CONNECTED TO CISCO 2503 VIA CISCO 2524
ACTING AS A FRAME RELAY SWITCH

2609A#show run
Building configuration...

Current configuration : 701 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2609A
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 ip address 192.168.1.107 255.255.255.0
!
interface Serial0
 ip address 172.16.17.2 255.255.255.0
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay map ip 172.16.17.1 901 broadcast
!
router rip
 network 172.16.0.0
 network 192.168.1.0
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line 1 8
line aux 0
line vty 0 4
 login
!
end



Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=36743&t=36743
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to