external network (192.168.1/24).
Nat overload on the dialer, and nat outside for a external address (map
192.168.1.1 to 172.31.1.1):

outside global 192.168.1.1 = 172.31.1.1 outside local
|
some router
|
dialer 192.168.254.1 (overload)
|
10.1.1/24

something like does works:

int eth 0
 ip nat inside
int dialer 1
 ip nat outside

ip nat inside source list Some-List interface dialer1 overload
ip nat outside source static 192.168.1.1 172.31.1.1

ip access-list extended Some-List
 permit ip any 172.31.1.1

ip route 172.31.1.0 255.255.255.0 Dialer 1

However, the translation is global per ip, not per port, so a internal host
can't connect at the same time to two different remote hosts translated in
this way.

Now, if only some ports are required I understand the translation should be
done per port in order to solve this problem:

ip nat outside source static tcp 192.1683.1.1 3001 172.31.1.1 3001

sh running shows the keyword "extendable" added at the end of that one.
Everything else the same.

Only, it doesn't seem to work (this is 11.3), and after half a day banging
my head on this issue I still didn't find the problem.
sh ip nat translations shows the problem:

Pro Inside global         Inside local          Outside local
Outside global
tcp 192.168.254.1:3518     10.1.1.14:3518       172.31.1.1:3001
172.31.1.1:3001

In other words the destination address is not translated.
Any idea what is missing or wrong ?

Heiko Herold

-- 
-- PREVINET S.p.A.            [EMAIL PROTECTED]
-- Via Ferretto, 1            ph  x39-041-5907073
-- I-31021 Mogliano V.to (TV) fax x39-041-5907087
-- ITALY




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=39420&t=39420
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to