Right,
    Think of the ospf "network" command as a range statement that you can
interpret like this: "If any of the interfaces falls within the given range,
make that interface participate in the OSPF process under the given area."
That means that you can either match the mask given on the interface, or
specify 0.0.0.0, they do the same thing.  Here's where you can minimize your
configuration:

Let's say you have the following 4 interfaces with the IP addresses listed,
and you wanted them all to be in area0:

int e0 192.168.0.0 255.255.255.0
int e1 192.168.1.0 255.255.255.0
int s0 192.168.2.0 255.255.255.0
int s1 192.168.3.0 255.255.255.0

Instead of typing:
config# router ospf 10
config-router# network 192.168.0.0 0.0.0.255 area 0
config-router# network 192.168.1.0 0.0.0.255 area 0
config-router# network 192.168.2.0 0.0.0.255 area 0
config-router# network 192.168.3.0 0.0.0.255 area 0
config-router# exit
config#
...

You could type this:
config# router ospf 10
config-router# network 192.168.0.0 0.0.3.255 area 0
! the above command could even be "network 192.168.0.0 0.0.255.255 area 0".
! It would have the exact same effect, assuming the router didn't have other
! interfaces in this range that were either not going to participate in
OSPF,
! or are going to be assigned to a different area.
config-router# exit
config#

The router will apply the "If any of the interfaces falls within the given
range, make that interface participate in the OSPF process under the given
area." statement and e0, e1, s0, and s1 will all become OSPF interfaces in
area 0 because the wildcard mask 0.0.3.255 is equivalent to the subnet mask
of 255.255.252.0, which is the CIDR mask of the four subnets.

HTH,
Kelly Cobean, CCNP, CCSA, ACSA, MCSE, MCP+I
Network Engineer
GRC International, Inc., an AT&T company




-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Lomker, Michael
Sent: Tuesday, April 09, 2002 2:28 PM
To: [EMAIL PROTECTED]
Subject: RE: OSPF network command question [7:40939]


If you had additional interfaces on the listed subnet then they would also
be included in OSPF.  The second method will only include the specified
interface.

> -----Original Message-----
> For example:
> interface fa0/0
>     ip address 172.168.1.1 255.255.255.0
>
> To advertise this network,  you can use two different
> commands and both works
> router ospf 10
>    network 172.168.1.0 0.0.0.255 area 0




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=40959&t=40939
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to