Hunt,
I guess you don't have the 203.147.154.0 route in the middle router.
however, you have a
defaut route in it. So, you will experience a routing loop. Check you tunnel
configuration as well. see the following from u :

 I have an OSPF connectivity problem.  I have 3 routers as follows:
>
>           OSPF Area 203.147.188.0                     OSPF Area 0
> Gw1.bne2 ------------------------  Gw2.bne -------------------Gw1.bne
>
> Gw1.bne2 is connecting to Gw2.bne with Serial 0/0:0 (203.147.255.186 /30)
> Gw2.bne is connecting back to Gw1.bne2 with Serial 0/0:0 (203.147.255.185
> /30)
>
> Gw2.bne is also connected to Gw1.bne with FastEth 0/0 (202.139.236.2 /24)
> Gw1.bne is connecting back to Gw2.bne with FastEth 0/1 (202.139.236.254
/24)
>
> Now I have 5 static routes at Gw1.bne2 (the left most Router) that I want
to
> redistributed into OSPF.
>
> ip route 203.147.154.0 255.255.255.128 203.147.188.65
> ip route 203.147.154.128 255.255.255.248 203.147.188.68
> ip route 203.147.154.136 255.255.255.248 203.147.188.69
> ip route 203.147.154.144 255.255.255.252 203.147.188.66
> ip route 203.147.154.148 255.255.255.252 203.147.188.67
>
> controller E1 0/0
>  channel-group 0 timeslots 1-31
> !
> !
> interface Tunnel0
>  description BNE2->Avior
>  ip address 10.255.255.2 255.255.255.252
>  no ip route-cache cef
>  tunnel source 203.147.255.186
>  tunnel destination 203.147.190.4
> !
> interface FastEthernet0/0
>  no ip address
>  ip route-cache flow
>  speed 100
>  full-duplex
> !
> interface FastEthernet0/0.5
>  encapsulation dot1Q 5
> !
> interface FastEthernet0/0.10
>  encapsulation dot1Q 10
>  ip address 10.15.15.254 255.255.255.0 secondary
>  ip address 203.147.188.254 255.255.255.0
>  ip access-group pfilter in
>  ip accounting access-violations
>  ip nbar protocol-discovery
> !
> interface FastEthernet0/0.999
>  encapsulation dot1Q 999
>  ip address 10.2.101.1 255.255.0.0
> !
> interface Serial0/0:0
>  description N7065870L to 96 Lytton Rd
>  ip address 203.147.255.186 255.255.255.252
>  ip nbar protocol-discovery
>  ip route-cache flow
>  load-interval 30
>  service-policy output voippol
> !
> router ospf 7496
>  log-adjacency-changes
>  redistribute connected
>  redistribute static subnets
>  passive-interface FastEthernet0/0.999
>  network 203.147.188.0 0.0.0.255 area 203.147.188.0
>  network 203.147.255.184 0.0.0.3 area 203.147.188.0
>
> At Gw1.bne2, it shows the subnets are learned via "statics"
>
> gw1.bne2#sh ip route 203.147.154.136
> Routing entry for 203.147.154.136/29
>   Known via "static", distance 1, metric 0
>   Redistributing via ospf 7496
>   Advertised by ospf 7496 subnets
>   Routing Descriptor Blocks:
>   * 203.147.188.69
>       Route metric is 0, traffic share count is 1
>
> When I goto Gw2.bne (middle router), I can see the routes in the OSPF
> Topology Table (all of them are learned from 203.147.255.186 - Gw1.bne2),
> but not the its routing table:-
>
> N.B:  I also tried to do a clear ip route 203.147.144.0/20, but no help.
> The same route came straight back
>
>   Type-5 AS External Link States
>
> 203.147.154.0   203.147.255.186 572         0x80000002 0xAC01   0
> 203.147.154.128 203.147.255.186 573         0x80000002 0xA40D   0
> 203.147.154.136 203.147.255.186 573         0x80000002 0x6246   0
> 203.147.154.144 203.147.255.186 573         0x80000002 0xFF9F   0
> 203.147.154.148 203.147.255.186 573         0x80000002 0xE5B4   0
>
> gw2.bne# sh ip route 203.147.154.136
> Routing entry for 203.147.144.0/20, supernet
>   Known via "ospf 7496", distance 110, metric 3, type inter area
>   Last update from 202.139.236.254 on FastEthernet0/0, 00:17:48 ago
>    Routing Descriptor Blocks:
>   * 202.139.236.254, from 203.147.255.156, 00:17:48 ago, via
FastEthernet0/0
>       Route metric is 3, traffic share count is 1
>
> However, if I goto Gw1.bne (the rightmost router), it can see all 5 subnets
> in the OSPF Topoloy Table and Routing Table
>
>   Type-5 AS External Link States
>
> 203.147.154.0   203.147.255.186 867         0x80000002 0xAC01   0
> 203.147.154.128 203.147.255.186 867         0x80000002 0xA40D   0
> 203.147.154.136 203.147.255.186 867         0x80000002 0x6246   0
> 203.147.154.144 203.147.255.186 867         0x80000002 0xFF9F   0
> 203.147.154.148 203.147.255.186 867         0x80000002 0xE5B4   0
>
> gw1.bne#sh ip route 203.147.154.136
> Routing entry for 203.147.154.136/29
>   Known via "ospf 7496", distance 110, metric 20, type extern 2, forward
> metric 52
>   Redistributing via ospf 7496
>   Last update from 202.139.236.2 on FastEthernet0/1, 00:49:30 ago
>    Routing Descriptor Blocks:
>   * 202.139.236.2, from 203.147.255.186, 00:49:30 ago, via FastEthernet0/1
>       Route metric is 20, traffic share count is 1
>
> As a result, when I do a trace from Gw1.bne (the rightmost router), it
> points it to Gw2.bne, but Gw2.bne points it back - Routing Loop   :(
>
> gw1.bne#trace 203.147.154.136
>
> Type escape sequence to abort.
> Tracing the route to 203.147.154.136
>
>   1 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 0 msec 4 msec 0 msec
>   2 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 0 msec
>   3 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 0 msec 4 msec 4 msec
>   4 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>   5 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>   6 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 0 msec
>   7 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 0 msec
>   8 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>   9 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  10 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>  11 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  12 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>  13 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  14 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 8 msec 4 msec
>  15 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 8 msec 4 msec
>  16 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 8 msec
>  17 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  18 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 8 msec 8 msec 4 msec
>  19 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 8 msec 4 msec
>  20 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 8 msec
>  21 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 12 msec 4 msec 4 msec
>  22 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 8 msec 8 msec
>  23 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 8 msec 8 msec
>  24 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 8 msec 8 msec
>  25 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 8 msec 12 msec
>  26 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 12 msec 8 msec 8 msec
>  27 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 4 msec 8 msec
>  28 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 8 msec 8 msec 8 msec
>  29 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 8 msec 8 msec
>  30 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 8 msec 8 msec 8 msec
> gw1.bne#
>
> Also, I have attached the config for Gw2.bne (Middle Router):-
>
> controller E1 0/0
>  channel-group 0 timeslots 1-31
> !
> !
> interface Loopback0
>  description Management
>  ip address 10.1.1.6 255.255.0.0
> !
> interface FastEthernet0/0
>  ip address 202.139.236.2 255.255.255.0
>  ip ospf message-digest-key 1 md5 7 0205534119541C14644F
>  speed 100
>  full-duplex
>  random-detect
> !
> interface Serial0/0:0
>  description N7065870L to Lvl5 Wickham St
>  ip address 203.147.255.185 255.255.255.252
>  ip nbar protocol-discovery
>  ip route-cache flow
>  service-policy output guaranteed
> !
> router ospf 7496
>  log-adjacency-changes
>  area 0 authentication message-digest
>  network 202.139.236.0 0.0.0.255 area 0
>  network 203.147.255.184 0.0.0.3 area 203.147.188.0
> !
> ip flow-export source Loopback0
> ip flow-export version 5
> ip flow-export destination 203.147.190.7 9992
> ip classless
> ip route 0.0.0.0 0.0.0.0 202.139.236.254
> ip route 203.32.10.0 255.255.255.0 203.147.255.186
> ip route 203.147.188.0 255.255.255.0 203.147.255.186
> no ip http server
>
> So why would Gw2.bne (the middle router) passed the Redistributed Routes to
> Gw1.bne while itself (Gw2.bne) is using the supernet??
>
> Thanks a lot
>
> Best Regards,
> Hunt Lee
Hunt Lee wrote:

> I have an OSPF connectivity problem.  I have 3 routers as follows:
>
>           OSPF Area 203.147.188.0                     OSPF Area 0
> Gw1.bne2 ------------------------  Gw2.bne -------------------Gw1.bne
>
> Gw1.bne2 is connecting to Gw2.bne with Serial 0/0:0 (203.147.255.186 /30)
> Gw2.bne is connecting back to Gw1.bne2 with Serial 0/0:0 (203.147.255.185
> /30)
>
> Gw2.bne is also connected to Gw1.bne with FastEth 0/0 (202.139.236.2 /24)
> Gw1.bne is connecting back to Gw2.bne with FastEth 0/1 (202.139.236.254
/24)
>
> Now I have 5 static routes at Gw1.bne2 (the left most Router) that I want
to
> redistributed into OSPF.
>
> ip route 203.147.154.0 255.255.255.128 203.147.188.65
> ip route 203.147.154.128 255.255.255.248 203.147.188.68
> ip route 203.147.154.136 255.255.255.248 203.147.188.69
> ip route 203.147.154.144 255.255.255.252 203.147.188.66
> ip route 203.147.154.148 255.255.255.252 203.147.188.67
>
> controller E1 0/0
>  channel-group 0 timeslots 1-31
> !
> !
> interface Tunnel0
>  description BNE2->Avior
>  ip address 10.255.255.2 255.255.255.252
>  no ip route-cache cef
>  tunnel source 203.147.255.186
>  tunnel destination 203.147.190.4
> !
> interface FastEthernet0/0
>  no ip address
>  ip route-cache flow
>  speed 100
>  full-duplex
> !
> interface FastEthernet0/0.5
>  encapsulation dot1Q 5
> !
> interface FastEthernet0/0.10
>  encapsulation dot1Q 10
>  ip address 10.15.15.254 255.255.255.0 secondary
>  ip address 203.147.188.254 255.255.255.0
>  ip access-group pfilter in
>  ip accounting access-violations
>  ip nbar protocol-discovery
> !
> interface FastEthernet0/0.999
>  encapsulation dot1Q 999
>  ip address 10.2.101.1 255.255.0.0
> !
> interface Serial0/0:0
>  description N7065870L to 96 Lytton Rd
>  ip address 203.147.255.186 255.255.255.252
>  ip nbar protocol-discovery
>  ip route-cache flow
>  load-interval 30
>  service-policy output voippol
> !
> router ospf 7496
>  log-adjacency-changes
>  redistribute connected
>  redistribute static subnets
>  passive-interface FastEthernet0/0.999
>  network 203.147.188.0 0.0.0.255 area 203.147.188.0
>  network 203.147.255.184 0.0.0.3 area 203.147.188.0
>
> At Gw1.bne2, it shows the subnets are learned via "statics"
>
> gw1.bne2#sh ip route 203.147.154.136
> Routing entry for 203.147.154.136/29
>   Known via "static", distance 1, metric 0
>   Redistributing via ospf 7496
>   Advertised by ospf 7496 subnets
>   Routing Descriptor Blocks:
>   * 203.147.188.69
>       Route metric is 0, traffic share count is 1
>
> When I goto Gw2.bne (middle router), I can see the routes in the OSPF
> Topology Table (all of them are learned from 203.147.255.186 - Gw1.bne2),
> but not the its routing table:-
>
> N.B:  I also tried to do a clear ip route 203.147.144.0/20, but no help.
> The same route came straight back
>
>   Type-5 AS External Link States
>
> 203.147.154.0   203.147.255.186 572         0x80000002 0xAC01   0
> 203.147.154.128 203.147.255.186 573         0x80000002 0xA40D   0
> 203.147.154.136 203.147.255.186 573         0x80000002 0x6246   0
> 203.147.154.144 203.147.255.186 573         0x80000002 0xFF9F   0
> 203.147.154.148 203.147.255.186 573         0x80000002 0xE5B4   0
>
> gw2.bne# sh ip route 203.147.154.136
> Routing entry for 203.147.144.0/20, supernet
>   Known via "ospf 7496", distance 110, metric 3, type inter area
>   Last update from 202.139.236.254 on FastEthernet0/0, 00:17:48 ago
>    Routing Descriptor Blocks:
>   * 202.139.236.254, from 203.147.255.156, 00:17:48 ago, via
FastEthernet0/0
>       Route metric is 3, traffic share count is 1
>
> However, if I goto Gw1.bne (the rightmost router), it can see all 5 subnets
> in the OSPF Topoloy Table and Routing Table
>
>   Type-5 AS External Link States
>
> 203.147.154.0   203.147.255.186 867         0x80000002 0xAC01   0
> 203.147.154.128 203.147.255.186 867         0x80000002 0xA40D   0
> 203.147.154.136 203.147.255.186 867         0x80000002 0x6246   0
> 203.147.154.144 203.147.255.186 867         0x80000002 0xFF9F   0
> 203.147.154.148 203.147.255.186 867         0x80000002 0xE5B4   0
>
> gw1.bne#sh ip route 203.147.154.136
> Routing entry for 203.147.154.136/29
>   Known via "ospf 7496", distance 110, metric 20, type extern 2, forward
> metric 52
>   Redistributing via ospf 7496
>   Last update from 202.139.236.2 on FastEthernet0/1, 00:49:30 ago
>    Routing Descriptor Blocks:
>   * 202.139.236.2, from 203.147.255.186, 00:49:30 ago, via FastEthernet0/1
>       Route metric is 20, traffic share count is 1
>
> As a result, when I do a trace from Gw1.bne (the rightmost router), it
> points it to Gw2.bne, but Gw2.bne points it back - Routing Loop   :(
>
> gw1.bne#trace 203.147.154.136
>
> Type escape sequence to abort.
> Tracing the route to 203.147.154.136
>
>   1 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 0 msec 4 msec 0 msec
>   2 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 0 msec
>   3 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 0 msec 4 msec 4 msec
>   4 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>   5 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>   6 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 0 msec
>   7 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 0 msec
>   8 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>   9 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  10 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>  11 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  12 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 4 msec
>  13 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  14 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 8 msec 4 msec
>  15 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 8 msec 4 msec
>  16 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 8 msec
>  17 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 4 msec 4 msec
>  18 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 8 msec 8 msec 4 msec
>  19 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 8 msec 4 msec
>  20 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 4 msec 8 msec
>  21 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 12 msec 4 msec 4 msec
>  22 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 8 msec 8 msec
>  23 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 8 msec 8 msec
>  24 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 4 msec 8 msec 8 msec
>  25 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 4 msec 8 msec 12 msec
>  26 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 12 msec 8 msec 8 msec
>  27 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 4 msec 8 msec
>  28 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 8 msec 8 msec 8 msec
>  29 fa0-0.gw2.bne.webcentral.com.au (202.139.236.2) 8 msec 8 msec 8 msec
>  30 fa0-1.gw1.bne.webcentral.com.au (202.139.236.254) 8 msec 8 msec 8 msec
> gw1.bne#
>
> Also, I have attached the config for Gw2.bne (Middle Router):-
>
> controller E1 0/0
>  channel-group 0 timeslots 1-31
> !
> !
> interface Loopback0
>  description Management
>  ip address 10.1.1.6 255.255.0.0
> !
> interface FastEthernet0/0
>  ip address 202.139.236.2 255.255.255.0
>  ip ospf message-digest-key 1 md5 7 0205534119541C14644F
>  speed 100
>  full-duplex
>  random-detect
> !
> interface Serial0/0:0
>  description N7065870L to Lvl5 Wickham St
>  ip address 203.147.255.185 255.255.255.252
>  ip nbar protocol-discovery
>  ip route-cache flow
>  service-policy output guaranteed
> !
> router ospf 7496
>  log-adjacency-changes
>  area 0 authentication message-digest
>  network 202.139.236.0 0.0.0.255 area 0
>  network 203.147.255.184 0.0.0.3 area 203.147.188.0
> !
> ip flow-export source Loopback0
> ip flow-export version 5
> ip flow-export destination 203.147.190.7 9992
> ip classless
> ip route 0.0.0.0 0.0.0.0 202.139.236.254
> ip route 203.32.10.0 255.255.255.0 203.147.255.186
> ip route 203.147.188.0 255.255.255.0 203.147.255.186
> no ip http server
>
> So why would Gw2.bne (the middle router) passed the Redistributed Routes to
> Gw1.bne while itself (Gw2.bne) is using the supernet??
>
> Thanks a lot
>
> Best Regards,
> Hunt Lee




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=42428&t=42411
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to