This one deserves a homily. I can sleep tonight after solving this one.

The age old question - how to get a /23 to propagate into classful /24
domain via redistribution.

I've been toying with this a while tonight.

The problem - an "in use" interface - token ring or ethernet - has a /23
assignment. Let's call it 160.160.2.1 255.255.254.0 just for reference. This
interface is in an OSPF or an EIGRP domain. The test is to redistribute this
route into a RIP domain so that there is full reachability from anyplace in
the RIP domain to any station in the OSPF / EIGRP domain. Oh yes, the RIP
domain is a /24 domain.

I tried the usual suspects.  The rundown is as follows:

1) Setting up loopbacks with a /32 address. Problem - overlapping addresses

2) area range command in OSPF. Problem - Cisco's idea of summarization is
the shortening of prefixes, not the lengthening. I tried variations of area
range:

area 222 range 160.160.2.0 255.255.255.0
area 222 range 160.160.3.0 255.255.255.0
area 222 range 160.160.2.0 255.255.254.0 not-advertise

I thought maybe I could get around what OSPF was doing by using the
no-advertise switch, and then using the area ranges with the /24's. The
no-advertise suppresses all subnets of the particular range. There appears
to be no way to circumvent this.

3) ip summary-address eigrp xxx etc interface command in EIGRP. Problem -
summarization still only seems to like the shortening of prefixes, not the
lengthening.

Scratching my head. OK., let's try thinking out of the box, to coin a
phrase.

Well, one thing that keeps gnawing at me. RIP sends version 1, but receives
version 1 and version 2 advertisements. OK. So how about on the
redistribution router, I simply change the RIP version from 1 to 2? Can it
be that easy? Apparently so, because it works.

In the particular case, I have the Huge Subnet on Router_2:

interface Loopback500
 ip address 160.160.2.1 255.255.254.0
 ip ospf network point-to-point
!
router ospf 123
 log-adjacency-changes
 network 160.160.2.0 0.0.1.255 area 222
 network 160.160.254.2 0.0.0.0 area 0

Router_1 is the redistribution router. It shows the OSPF route in question:

Router_1#
Router_1#ir ospf
     160.160.0.0/16 is variably subnetted, 20 subnets, 8 masks
O IA    160.160.2.0/23 [110/26] via 160.160.255.2, 00:31:49, TokenRing0

On Router_1 I placed a loopback as follows:

interface Loopback500
 ip address 160.160.3.254 255.255.255.255

and I completed the task by making changes to the rip configuration:

router rip
 version 2
 redistribute ospf 123 metric 6
 network 160.160.0.0
 no auto-summary

and then doing a rip summary address on the appropriate RIP interface:

interface Serial0
 ip address 160.160.127.1 255.255.255.0
 no ip route-cache
 ip summary-address rip 160.160.2.0 255.255.254.0
( summarizes the /32 on interface loopback 500 )

the result is that Router_4, a RIP ver 1 router, still sees the /23 network

Router_4#ir rip
     160.160.0.0/16 is variably subnetted, 30 subnets, 7 masks
R       160.160.2.0/23 [120/6] via 160.160.127.1, 00:00:13, Serial0

OK, so that's one way to do it.

I've seen discussion of using tunnel interfaces and secondary addressing as
workarounds to this problem over on the CCIE list in the past. I know that
several of the CCIE Lab study materials have tasks like this, leading me to
believe that this is something one should add to the bag of tricks one needs
when actually sitting in one of the testing centers.

What is it my self help guru likes to say?

"There is always a way."

Peaceful evenings. Crisp autumn air.

Goodnight everyone.

--

Chuck




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=55773&t=55773
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to