came across this one the other day. I believe it was prepared by someone
inside Cisco. I did not find any copyright notices, so I am assuming it is
ok to post here. for details as to what all these things really mean, check
out the Cisco documentation, as well as any number of other resources, free
and otherwise, that have been mentioned on this news group.

---------------------------------------

3550 How To Quick Reference

System Name:
cat2-3550(config)#hostname Catalyst

System Login Banner:
Cat1-3550(config)#banner login # Authorized Users Only #

Name an interface:
cat2-3550(config)#int fa0/1
cat2-3550(config-if)#description R1e0

Enable Portfast on an Interface:
cat2-3550(config-if)#spanning
cat2-3550(config-if)#spanning-tree portfast

Set Duplex on an Interface:
cat2-3550(config)#int fa0/1
cat2-3550(config-if)#duplex half

Set Port Speed on an Interface:
cat2-3550(config)#int fa0/1
cat2-3550(config-if)#speed 10

Set DNS Server:
cat2-3550(config)#ip name-server 4.1.1.1

Set VTP Domain and Name:
cat2-3550(config)#vtp domain hello
cat2-3550(config)#vtp mode transparent

Create Vlan and Name:
SW1(vlan)#vlan 10 name RED
SW1(vlan)#vlan 20 name BLUE
SW1(vlan)#exit

Set Vlan IP address and priority:
SW1#config t
SW1(config)#interface vlan 20
SW1(config)#spanning-tree vlan 20 priority 20
SW1(config-subif)#ip addr 1.1.1.1 255.255.255.0

Allow Only Specific Multiple Vlans on Trunk in One Statement:
interface FastEthernet0/24
switchport trunk encapsulation isl
switchport trunk allowed vlan 1,2,4,5,10,12-14,1002-1005
switchport mode trunk
no ip address

Show All Trunks and Information:
cat2-3550#show interface trunk

Set Switch to be Root of Vlan 66 using Root Command:
Cat1-3550(config)#spanning-tree vlan 101 root primary

Set Switch to be Root of Vlan 66 Without using Root Command:
Cat1-3550(config)#spanning-tree vlan 101 priority 0

Assign Default Gateway:
SW1(config)#ip default-gateway 1.1.1.2

Create Ether Channel Across Two Switches:
First Switch:
SW1(config)#int port-channel 1
SW1(config-if)#switchport trunk encapsulation isl
SW1(config-if)#switchport mode trunk

SW1(config)#int fa 0/23
SW1(config-if)#switchport trunk encap isl
SW1(config-if)#switchport mode trunk
SW1(config-if)#channel-group 1 mode auto

SW1(config)#int fa 0/24
SW1(config-if)#switchport trunk encap isl
SW1(config-if)#switchport mode trunk
SW1(config-if)#channel-group 1 mode auto

Second Switch:
SW2(config)#int port-channel 1
SW2(config-if)#switchport trunk encapsulation isl
SW2(config-if)#switchport mode trunk

SW2(config)#int fa 0/23
SW2(config-if)#switchport trunk encap isl
SW2(config-if)#switchport mode trunk
SW2(config-if)#channel-group 1 mode auto

SW2(config)#int fa 0/24
SW2(config-if)#switchport trunk encap isl
SW2(config-if)#switchport mode trunk
SW2(config-if)#channel-group 1 mode auto

Assign Vlan to Interface:
SW1(config)#int fastEthernet 0/2
SW1(config-if)#switchport access vlan 20
SW1(config-if)#no shutdown

SW1(config)#interface fastEthernet 0/3
SW1(config-if)#switchport access vlan 10
SW1(config-if)#no shutdown

Create Trunk on Interface:
SW1(config)#int fa 0/1
SW1(config-if)#switchport trunk encap isl
SW1(config-if)#switchport mode trunk



Assign Ether Channel to Interface:
SW1(config)#interface fa0/23
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#channel-group 1 mode auto (other side use desirable)

SW1(config)#interface fa0/24
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#channel-group 1 mode auto (other side use desirable)


SPAN on port interfaces:
SW2#config t
SW2(config)#no monitor session 1
SW2(config)#monitor session 1 source interface fa0/3
SW2(config)#monitor session 1 destination interface fa0/11
SW2(config)#end

Using SPAN on vlan interfaces:
SW2#config t
SW2(config)#no monitor session 1
SW2(config)#monitor session 1 source vlan 10
SW2(config)#monitor session 1 destination interface fa0/11 (any encap here)
SW2(config)#end
SW2#sh monitor session 1
Session 1
---------
Source Ports:
    RX Only:       None
    TX Only:       None
    Both:          Fa0/3
Source VLANs:
    RX Only:       None
    TX Only:       None
    Both:          None
Destination Ports: Fa0/11
    Encapsulation: Native
Filter VLANs:      None

Time Stamp Debug and Log Messages with Absolute Time:
service timestamps debug datetime
service timestamps log datetime

Stop DNS Lookup:
no ip domain-lookup


Allow Packets to go to a Supernet:
ip classless

Disable HTTP Server:
no ip http server



Enabling Syslog:
logging history informational   (This sets the logging level)
logging facility local6
logging source-interface Loopback0
logging 150.50.111.100

Configure SNMP and Restrict Access:
snmp-server community hello RO 12
snmp-server community hellorw RW 13
access-list 12 permit 150.50.0.0 0.0.255.255
access-list 13 permit 150.50.16.0 0.0.0.255
access-list 13 permit 150.50.111.0 0.0.0.255

Disabling TCP and UDP small server:
R1(config)#no service tcp-small-servers
R1(config)#no service udp-small-servers

Enabling Storm Control on an Interface:
cat1-3550(config)#int fa0/6
cat1-3550(config-if)#storm-control broadcast level 50
cat1-3550(config-if)#storm-control multicast level 25
cat1-3550(config-if)#storm-control un
-------------------------------------------------------

--
TANSTAAFL
"there ain't no such thing as a free lunch"




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=61392&t=61392
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to