Hi,

On Wed, 2005-12-14 at 20:39 +0100, Guilhem Lavaux wrote:
> Mark, actually I don't see what benefit we could get of moving some 
> Array.sort & copy to getSerialPersistentFields. So I have not done it 
> for the moment.

No problem, I just hoped we could safe some duplicate code, but I didn't
actually check whether that could actually be done.

> +
> +     if (fields == ObjectStreamClass.INVALID_FIELDS)
> +       throw new InvalidClassException("serialPersistentFields in class " + 
> osc.getName() + " is invalid");
> +

Better to use the 2 argument constructor
InvalidClassException(String classname, String message) here.
Also try to keep line under 80 chars.

Cheers,

Mark

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
Classpath-patches mailing list
Classpath-patches@gnu.org
http://lists.gnu.org/mailman/listinfo/classpath-patches

Reply via email to