On Tue, 20 Dec 2022 23:25:30 GMT, Harshitha Onkar <[email protected]> wrote:
> ViewportOverlapping was failing intermittently on Windows (Win10 & 11). Added
> robot.setAutoWaitForIdle() to ViewportOverlapping and its base class
> (OverlappingTestBase) to stabilize the test.
>
> Additionally added awt & swings tests to exclusiveAccess.dir in TEST.ROOT.
Maybe also expand imports in `OverlappingTestBase.java`?
test/jdk/java/awt/Mixing/AWT_Mixing/OverlappingTestBase.java line 464:
> 462: robot.setAutoWaitForIdle(true);
> 463: }catch(Exception ignorex) {
> 464: }
Does it make sense to extract this code into a new method?
-------------
PR: https://git.openjdk.org/jdk/pull/11747