On Thu, 4 Dec 2025 19:41:24 GMT, Alexey Ivanov <[email protected]> wrote:
>> Phil Race has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> 4617681
>
> src/java.desktop/share/classes/java/awt/image/BufferedImage.java line 297:
>
>> 295: * A {@code DataBuffer} is a container for one or more banks of
>> 296: * Java primitive arrays so the number of samples that can be
>> 297: * stored are limited by the maximum size of a Java array.
>
> Suggestion:
>
> * A {@code DataBuffer} is a container for one or more banks of
> * Java primitive arrays, so the number of samples that can be
> * stored is limited by the maximum size of a Java array.
>
>
> A comma before _“so”_ improves readability by separating the dependent clause.
>
> “*the number* of samples … is,” the verb should be singular, isn't it?
fixed
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/27640#discussion_r4212111094