There's also a middle ground:

(defn my-fn2 [input]
  (op5
   (op4
    (op1 input)
    (op2 input))))

If your "op" names are descriptive, this can still be very easy to
read, with significantly fewer characters than the "let" version
(you'll get use to reading inside-out quickly).  You can also easily
add per-expression end-of-line comments this way.

That said, I end up using all three versions depending on the length
of the code, how clear the purpose is from the function names, etc.
None is inherently best IMHO, it's just a matter of taste and
circumstance.

Cheers,
Jason

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Clojure" group.
To post to this group, send email to clojure@googlegroups.com
To unsubscribe from this group, send email to 
clojure+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/clojure?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to