On Sun, Aug 12, 2012 at 11:22:55AM -0700, Takahiro Hozumi wrote:
> > (filter (partial not nil?) coll)
> You mean (filter (comp not nil?) coll).
> I'm not sure which is more readable, but thanks for Meikel and Alex, I now 
> prefer (remove nil? coll).

remove is better in this case, but for posterity (comp not nil?) can be
spelled as (complement nil?)

Robert

-- 
You received this message because you are subscribed to the Google
Groups "Clojure" group.
To post to this group, send email to clojure@googlegroups.com
Note that posts from new members are moderated - please be patient with your 
first post.
To unsubscribe from this group, send email to
clojure+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/clojure?hl=en

Reply via email to