On 07/11/2013 09:06 AM, Stephen Kelly wrote: > Role 2 is probably more common. > > In cmake code you mean?
Yes. > I imagine there are lots of bash scripts or aliases > which invoke cmake with -DCMAKE_INSTALL_PREFIX (I use an alias). Yes, and this makes role 1 even more common. [smacks forehead] > I think CMAKE_EXTERNAL_INSTALL_PREFIX would be a better name. Assuming we don't go back to CMAKE_TARGET_INSTALL_PREFIX as a replacement for role 2, let's identify the semantics of a new variable for role 1 and then choose the name. We can call it CMAKE_EXTERNAL_INSTALL_PREFIX for purpose of discussion here but I'm not satisfied by the name yet. Based on the above forehead smack CMAKE_EXTERNAL_INSTALL_PREFIX will have to be at most optional, similar to DESTDIR but able to replace CMAKE_INSTALL_PREFIX rather than just prepend to it. Currently the cmake_install.cmake scripts are generated with the default CMAKE_INSTALL_PREFIX from CMake configuration time. Is this as simple as changing that default to be based on the new variable but still calling it CMAKE_INSTALL_PREFIX in the install scripts? Basically anywhere that prepends DESTDIR can be potentially influenced by the new variable. > I'd prefer the ability to make CMAKE_HOST_INSTALL_PREFIX mean 'the location > to install host tools when doing a HOST+TARGET build' in the future. Yes, that meaning for CMAKE_HOST_INSTALL_PREFIX would be even more consistent with the CMAKE_HOST_* convention for cross-compiling. We can reserve the name for that future purpose. -Brad -- Powered by www.kitware.com Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ Follow this link to subscribe/unsubscribe: http://public.kitware.com/cgi-bin/mailman/listinfo/cmake-developers
