Mike I entered a ticket for a bug I found in the 1.5 devel branch. We might need a function if there isnt one already that validates that any IPV4/6 address that is entered into the CLI is validated. See my comments below:
Cobbler 1.5 devel version allows --gateway ip addresses to not be formated correctly. This should exit with an error when an incorrect address is used. Notice commas and a missing octet is allowed. We should also be confirming that --ip has similar behaviour. # cobbler system edit --name=host --gateway=10.128.200.1 # cobbler system edit --name=host --gateway=10.128.1 # cobbler system edit --name=host --gateway=10.128.200,1 # cobbler system edit --name=host --gateway=10.128,200,1 # cobbler system edit --name=host --gateway=10.128.200,1 # cobbler sync Internet Systems Consortium DHCP Server 4.0.0 Copyright 2004-2007 Internet Systems Consortium. All rights reserved. For info, please visithttp://www.isc.org/sw/dhcp/ /etc/dhcpd.conf line 211: too few numbers. option routers 10.128.200, /etc/dhcpd.conf line 212: semicolon expected. filename "/pxelinux.0" /etc/dhcpd.conf line 1138: too few numbers. option routers 10.128.200, /etc/dhcpd.conf line 1139: semicolon expected. filename "/pxelinux.0" Configuration file errors encountered -- exiting This version of ISC DHCP is based on the release available on ftp.isc.org. Features have been added and other changes have been made to the base software release in order to make it work better with this distribution. Please report for this software via the Red Hat Bugzilla site: http://bugzilla.redhat.com exiting. /usr/sbin/dhcpd -t failed
_______________________________________________ cobbler mailing list [email protected] https://fedorahosted.org/mailman/listinfo/cobbler
