On Sep 1, 2008, at 3:48 PM, Godfrey Van Der Linden wrote:

On 02/09/2008, at 8:26, Ben Trumbull <[EMAIL PROTECTED]> wrote:

- (void) awakeFromInsert
{
  [super awakeFromInsert];

_rect = [NSEntityDescription insertNewObjectForEntityForName:@"Rect"
inManagedObjectContext:[self managedObjectContext]];
  [_rect retain];

_color = [NSEntityDescription insertNewObjectForEntityForName:@"Color"
inManagedObjectContext:[self managedObjectContext]];
  [_color retain];
}

This code is not KVO compliant, which is required for Core Data to maintain object relationships. Add calls to will/ didChangeValueForKey:

- Ben

Would self._rect = ... Etc also make it compliant? And easier to read.

No, these are ivars not properties.  Renaud said this was on Tiger.

- Ben

_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to [EMAIL PROTECTED]

Reply via email to