On Mon, Apr 26, 2010 at 9:24 AM, David Duncan <david.dun...@apple.com> wrote:
> FYI "Create" is for functions, "new" is for methods. The analyzer won't 
> recognize one where the other is proper. There are also adornments you can 
> use to override the analyzer's understanding, but I can't recall them right 
> now.

They can be found here: http://clang-analyzer.llvm.org/annotations.html

I would advise sticking with the correct naming scheme, rather than
using the annotations to override their meaning. The annotations are
most useful when you have a delegate method that needs to return a
retained reference (-foo:newBar:). The analyzer won't pick up on "new"
anywhere but at the beginning of the method name.

--Kyle Sluder
_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to