On Apr 26, 2010, at 6:57 PM, Philip Mobley wrote:

> Question:  is the BELOW method named appropriately?
> 
> - (UIImage *) getImageWithTag:(NSString *)tag;

Usually Cocoa method names drop the “get” prefix, so ideally the name would 
just be “imageWithTag:”.

But yes, there’s no need to say “copy” since you’re not creating copies of the 
images. (And even if you were, you could just autorelease them before returning 
them, so the caller wouldn’t have to worry about releasing them; so you 
wouldn’t need to call it out in the method name.)

—Jens_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to