On Apr 15, 2011, at 1:51 AM, Scott Anguish wrote:

> The directory is named a name derived from the file
> 
> so /tmp/boo/Friday
> 
> and when it encounters a file that has more specific information, it should 
> be renamed
> 
> /tmp/boo/Friday-APPL
> 
> that should rename the existing directory with the existing fills and then 
> copy all the new files to the new path name


>>>                             newShootPath=[shootPath 
>>> stringByAppendingString:@“-APPL”];
>>>                             // make sure I’ve not already done this
>>>                             if (![self directoryExists:newShootPath]) {
>>> 
>>>                                     success=[fileManager 
>>> moveItemAtPath:shootPath toPath:newShootPath error:&theError];
>> 
>> Why not log both shootPath and newShootPath right here, before the move?  
>> What does it show?
> 
> It shows the correct values.
> 
> shootPath is /tmp/boo/Friday
> newPath is /tmp/boo/Friday-APPL
> 
> the odd thing is the move is creating the /tmp/boo/Friday-APPL directory, 
> rather than just renaming the existing one.

OK, so now I'm wondering what your -directoryExists: method does.  Also, what 
creates the directory?

Put another way, are you sure that /tmp/boo/Friday-APPL does not exist at the 
point where you're invoking -moveItemAtPath:... ?

Regards,
Ken

_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to