Script 'mail_helper' called by obssrc
Hello community,

here is the log from the commit of package aquamarine for openSUSE:Factory 
checked in at 2026-07-17 01:44:45
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/aquamarine (Old)
 and      /work/SRC/openSUSE:Factory/.aquamarine.new.24530 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "aquamarine"

Fri Jul 17 01:44:45 2026 rev:10 rq:1366208 version:0.12.1

Changes:
--------
--- /work/SRC/openSUSE:Factory/aquamarine/aquamarine.changes    2026-01-06 
17:46:50.555200595 +0100
+++ /work/SRC/openSUSE:Factory/.aquamarine.new.24530/aquamarine.changes 
2026-07-17 01:45:25.809192737 +0200
@@ -1,0 +2,57 @@
+Tue Jul 14 10:52:32 UTC 2026 - Nassim Lhadj <[email protected]>
+
+- Update to aquamarine version 0.12.1:
+  - New major release, includes a new ABI-breaking release (0.12.0)
+  - Changes in version 0.12.1:
+    * drm: avoid redundant identity ctm modesets
+    * headless: don't use raw this in lambda capture without checking
+    * backend/headless: fix framecb never firing
+  - Changes from version 0.12.0:
+    - A New ABI-breaking release
+    * drm: CRTC starvation recovery + clear stale page-flip state after suspend
+    * FormatUtils: null-check drmGetFormatModifierName result
+    * drm: skip unchanged connector_state on page-flips
+    * backend: avoid duplicate auto-named outputs
+    * drm: clear stale color state on modeset
+    * drm: re-read EDID on resume to detect dock port swaps
+    * drm: fall back to first render node on single-renderD systems when 
parent-syspath match fails
+    * output/state: init ctm to identity
+    * session: Add AQ_NO_KMS_REQUIREMENT environment variable for bypassing 
KMS requirement
+    * backend: remove trailing newlines from libseat and libinput logs
+    * Fix DisplayLink/evdi monitor hotplug
+    * drm: fix crash on null crtc in getGammaSize/getDeGammaSize
+  - Changes from version 0.11.0:
+    * headless: hold ref in next frame timer
+    * headless: verify fn is valid before calling
+    * backend/headless: implement FPS caps for headless outputs
+    * backend: move logger to backend
+    * backend: add freeDrmDevice on error in initDmabuf
+    * drm: convert vd path before compare with explicit device path
+    * Remove Unnecessary Modeset After Restoring from VT
+    * output: fix degammalut typo
+    * libinput: fix pad groups not being ref'd
+    * modifiers: add drmModifierToName and print names
+    * backend: read idle timer
+    * renderer: set EGL_CONTEXT_RELEASE_BEHAVIOR_KHR if supported
+    * atomic fixes
+    * drm: use parent device matching for render nodes
+    * drm: ignore redundant tiled display connectors
+    * drm: keep secondary renderers alive only when they're needed
+    * backend: fix use-after-free of logger during teardown
+    * drm: make pageflips drive the frames
+    * Split input and output buffer attachments
+    * drm: re-send HDR metadata blob on modeset
+    * drm: reduce duplicated code in render creation
+    * output: add a pendingPageFlips() method
+    * drm/renderer: glFlush when clearing buffers
+    * drm: re-send ctm blob on modeset
+    * Improve and optimize timer FD logic
+    * backend/drm: fix multi-GPU buffer import failure during restoreAfterVT
+    * backend: include algorithm header
+    * backend: handle unhandled libinput switch enum with default case
+    * drm: guard logging in connector disconnect to avoid null dereference
+    * libinput: method to get libinput_tablet_tool from ITabletTool
+    * CI: use org-wide actions
+    * refactor: avoid repeated vector access in backend and DRM loops
+    
+-------------------------------------------------------------------

Old:
----
  aquamarine-0.10.0.tar.xz

New:
----
  aquamarine-0.12.1.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ aquamarine.spec ++++++
--- /var/tmp/diff_new_pack.zE9bA5/_old  2026-07-17 01:45:26.505216222 +0200
+++ /var/tmp/diff_new_pack.zE9bA5/_new  2026-07-17 01:45:26.509216357 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package aquamarine
 #
-# Copyright (c) 2025 SUSE LLC and contributors
+# Copyright (c) 2026 SUSE LLC and contributors
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,13 +16,13 @@
 #
 
 
-%define sover   9
+%define sover   11
 %define _description %{expand:
 Aquamarine is a very light linux rendering backend library. It
 provides basic abstractions for an application to render on a Wayland
 session (in a window) or a native DRM session.}
 Name:           aquamarine
-Version:        0.10.0
+Version:        0.12.1
 Release:        0
 Summary:        Rendering backend library
 License:        BSD-3-Clause

++++++ aquamarine-0.10.0.tar.xz -> aquamarine-0.12.1.tar.xz ++++++
++++ 2670 lines of diff (skipped)

++++++ aquamarine.obsinfo ++++++
--- /var/tmp/diff_new_pack.zE9bA5/_old  2026-07-17 01:45:26.773225265 +0200
+++ /var/tmp/diff_new_pack.zE9bA5/_new  2026-07-17 01:45:26.781225535 +0200
@@ -1,5 +1,5 @@
 name: aquamarine
-version: 0.10.0
-mtime: 1763922789
-commit: a20a0e67a33b6848378a91b871b89588d3a12573
+version: 0.12.1
+mtime: 1781194626
+commit: 06669631175b4db2383b94e7f8c13f45a9d28757
 

Reply via email to