This is an automated email from the ASF dual-hosted git repository.

tvb pushed a change to branch jmac/virtual_directories_pre_rebase
in repository https://gitbox.apache.org/repos/asf/buildstream.git.


      at 7f99207  storage: Add __init__.py

This branch includes the following new commits:

     new 480c018  Add BST_VIRTUAL_DIRECTORY flag for element plugins
     new 59fb915  Sandbox.py: Rename __root to _root to allow its use by 
subclasses.
     new 227bc20  Add the virtual directory class 'Directory' and one 
implementation.
     new 9aa7db2  sandbox.py: Two functions to get virtual directories
     new 1a2e4cc  _stream.py: Convert to virtual directories.
     new 753566f  element.py: Conversion to use virtual directories
     new 0325fd9  plugins/elements/compose.py: Convert to virtual directories
     new 5d27736  plugins/elements/import.py: Convert to virtual directories
     new 8d5f872  sandbox: Remove instances of get_directory
     new e265478  plugins/elements/stack.py: Convert to virtual directories
     new d5d8d58  scriptelement.py: Convert to virtual directories
     new 7f99207  storage: Add __init__.py

The 12 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Reply via email to