[ 
https://issues.apache.org/jira/browse/CASSANDRA-8099?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14591772#comment-14591772
 ] 

Benedict commented on CASSANDRA-8099:
-------------------------------------

bq.  I did had forgotten to actually handle the reverse case in the merger
bq. This is something that was broken by the alternative patch in particular 
and would require some care.

Do we have test coverage of these? I didn't notice them breaking :(

>From a nomenclature standpoint, I would like to suggest we relabel the marker 
>types to (something like) {{UPPER/LOWER}}, so that _internally_ we can refer 
>to either as an open marker without confusion. Right now, the concept is 
>blurred, because we treat close markers as open markers when operating in 
>reverse, and IMO this hinders clarity. 

On the matter of the method for dealing with RTs, I agree with the majority of 
your points. However to improve the ugliness of {{MergedUnfiltered}} and remove 
the double persistence, why not introduce a special kind of RTM, of type 
{{BOUNDARY}}, which just has two timestamps. That's basically what the 
{{MergedUnfiltered}} is, so why not save space and improve clarity by promoting 
it to a first class concept? Unpicking them at merge when performing GC 
shouldn't be onerous.

I'm dubious about introducing more method calls to be invoked on every Cell, to 
permit the rare case of two atoms after one merge result. That's a code 
complexity and execution cost incurred for the uncommon case, but paid by all.

> Refactor and modernize the storage engine
> -----------------------------------------
>
>                 Key: CASSANDRA-8099
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8099
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Sylvain Lebresne
>            Assignee: Sylvain Lebresne
>             Fix For: 3.0 beta 1
>
>         Attachments: 8099-nit
>
>
> The current storage engine (which for this ticket I'll loosely define as "the 
> code implementing the read/write path") is suffering from old age. One of the 
> main problem is that the only structure it deals with is the cell, which 
> completely ignores the more high level CQL structure that groups cell into 
> (CQL) rows.
> This leads to many inefficiencies, like the fact that during a reads we have 
> to group cells multiple times (to count on replica, then to count on the 
> coordinator, then to produce the CQL resultset) because we forget about the 
> grouping right away each time (so lots of useless cell names comparisons in 
> particular). But outside inefficiencies, having to manually recreate the CQL 
> structure every time we need it for something is hindering new features and 
> makes the code more complex that it should be.
> Said storage engine also has tons of technical debt. To pick an example, the 
> fact that during range queries we update {{SliceQueryFilter.count}} is pretty 
> hacky and error prone. Or the overly complex ways {{AbstractQueryPager}} has 
> to go into to simply "remove the last query result".
> So I want to bite the bullet and modernize this storage engine. I propose to 
> do 2 main things:
> # Make the storage engine more aware of the CQL structure. In practice, 
> instead of having partitions be a simple iterable map of cells, it should be 
> an iterable list of row (each being itself composed of per-column cells, 
> though obviously not exactly the same kind of cell we have today).
> # Make the engine more iterative. What I mean here is that in the read path, 
> we end up reading all cells in memory (we put them in a ColumnFamily object), 
> but there is really no reason to. If instead we were working with iterators 
> all the way through, we could get to a point where we're basically 
> transferring data from disk to the network, and we should be able to reduce 
> GC substantially.
> Please note that such refactor should provide some performance improvements 
> right off the bat but it's not it's primary goal either. It's primary goal is 
> to simplify the storage engine and adds abstraction that are better suited to 
> further optimizations.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to