[ 
https://issues.apache.org/jira/browse/CASSANDRA-2124?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12992997#comment-12992997
 ] 

Vivek Mishra commented on CASSANDRA-2124:
-----------------------------------------

Patch attached:
1) Code style comments suggested by Eric, has been incorporated.

2) Sorry, I should have been clearer here. I think the .jdbc suffixed package 
name (like you had it) is best, I just meant that it should live under 
drivers/java. So either o.a.c.cql.driver.jdbc, or o.a.c.cql.jdbc would be OK 
with me.
<vivek> refactored to move into o.a.c.cql.driver.jdbc.</vivek>

Yeah, it's somewhat awkward in that it needs to connect to a running instance 
of Cassandra. I wonder if o.a.c.service.EmbeddedCassandraService would be of 
help here.
<vivek> Done. Test running with EmbeddedCassandraService().</vivek>

Also, JUnit should invoke setUp() and tearDown() for you, so I think you could 
rename setUpInternal() to setUp(), and remove all of the per-test invocations 
of it and tearDown().
<vivek> done</vivek>

Additionally, it looks like CassandraResultSet creates String instances for 
column names and values, which is really going to limit the utility. Do you 
have plans to change that?
<vivek> Changes made. Thought to add generics with in place of Object, but 
seems overhead.</vivek>

•what is the purpose of replacing/setting the security manager in 
CassandraDriver?
<vivek> Reason to add this was as initially thought to introduce remote 
interface layer on top of driver. Now removed. </vivek>





> JDBC driver for CQL
> -------------------
>
>                 Key: CASSANDRA-2124
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2124
>             Project: Cassandra
>          Issue Type: New Feature
>          Components: API
>            Reporter: Eric Evans
>            Assignee: Vivek Mishra
>            Priority: Minor
>              Labels: cql
>         Attachments: Cassandra-2124_v1.0, cassandra-0.7.1-2124_v2.0
>
>
> A simple connection class and corresponding pool was created for CQL as a 
> part of CASSANDRA-1710, but a JDBC driver (either in addition to, or as a 
> replacement for) would also be interesting.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply via email to