[ 
https://issues.apache.org/jira/browse/CASSANDRA-9054?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15384814#comment-15384814
 ] 

Blake Eggleston commented on CASSANDRA-9054:
--------------------------------------------

bq. We can (and should) take an incremental approach to changes like this 
instead of Big-Banging it.

Agreed.

So the refactor in general seems good, but there are things that could be 
cleaned up a bit: 

AuthSetup:
* I think AuthConfig would be a more descriptive name for this class
* Instead of explaining where it was refactored from, could you explain the 
purpose of the class, and use the javadoc format?
* there are empty '//' comments in applyAuthz method

StorageService:
* You've added a todo in the constructor about only registering verb handlers 
in daemon mode. Although the messaging service will be instantiated here, 
nothing important gets started as far as I can tell. I think you can just leave 
this as is.

Misc:
* FBUtilities / DatabaseDescriptor: Could you explain the reasoning behind the 
class level comment, and use the javadoc format?
* There are unused {{Config}} or {{DatabaseDescriptor}} imports in the 
following classes: CacheService, CompactionManager, CQLSSTableWriterLongTest, 
SSTableExpiredBlockers, SSTableLevelResetter, SSTableLoaderTest, 
SSTableOfflineRelevel, StandaloneScrubber, StandaloneSplitter, & 
StandaloneVerifier, StorageService

> Break DatabaseDescriptor up into multiple classes.
> --------------------------------------------------
>
>                 Key: CASSANDRA-9054
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9054
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jeremiah Jordan
>            Assignee: Robert Stupp
>             Fix For: 3.x
>
>
> Right now to get at Config stuff you go through DatabaseDescriptor.  But when 
> you instantiate DatabaseDescriptor it actually opens system tables and such, 
> which triggers commit log replays, and other things if the right flags aren't 
> set ahead of time.  This makes getting at config stuff from tools annoying, 
> as you have to be very careful about instantiation orders.
> It would be nice if we could break DatabaseDescriptor up into multiple 
> classes, so that getting at config stuff from tools wasn't such a pain.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to