[ 
https://issues.apache.org/jira/browse/CASSANDRA-12661?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15965859#comment-15965859
 ] 

Robert Stupp commented on CASSANDRA-12661:
------------------------------------------

There are some other issues with the patch:
* it silently changes the default of {{gc_warn_threshold_in_ms}} from 0 to 1000
* the change of {{final static long}} to {{private volatile static long}} - the 
{{volatile}} is unnecessary here, especially since {{handleNotification}} is 
running in the JVM GC threads and therefore within a potential stop-the-world 
phase
* the first check  in {{setGcWarnThresholdInMs}} is wrong
* the second {{if}} in {{setGcLogThresholdInMs}} is wrong
* due to the checks in the implementation, the order of calls to 
{{setGcLogThresholdInMs}} + {{setGcWarnThresholdInMs}} depend on the _current_ 
values, which should not be the case. this could be changed by having just one 
method that changes both values.
* i’m missing a reason for the new {{if (!mbs.isRegistered(me))}} and the other 
change in the static initializer
* The javadoc change, should be formatted as all other comments - i.e. {{/*}} 
in the first line and the first line of text in the next one.
* {{GCInspectorTest}} is missing the _mandatory_ copyright header
* The added {{@Override}} annotations should be removed (according to C* code 
style)
* The utest failure should be fixed


> Make gc_log and gc_warn settable at runtime
> -------------------------------------------
>
>                 Key: CASSANDRA-12661
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-12661
>             Project: Cassandra
>          Issue Type: New Feature
>            Reporter: Edward Capriolo
>            Assignee: Edward Capriolo
>            Priority: Minor
>
> Changes:
> * Move gc_log_threshold_in_ms and gc_warn_threshold_in_ms close together in 
> the config
> * rename variables to match properties
> * add unit tests to ensure hybration
> * add unit tests to ensure variables are set propertly
> * minor perf (do not consturct string from buffer f not logging)



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to