[ 
https://issues.apache.org/jira/browse/CASSANDRA-15553?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Blake Eggleston updated CASSANDRA-15553:
----------------------------------------
    Status: Changes Suggested  (was: Review In Progress)

looks good, I just have a few minor things:

 
 * CassandraValidationIterator.java:61 - stray whitespace at top of class def
 * LocalSessions$Listener - it would be nice to have a more descriptive method 
name `onIncrementalStateChange` or something. We have at least a few listeners 
with generic `onStateChange` methods
 *  RepairSession#stateChange - we should return after forcingShutdown. 
Alternatively, we could use {{Iterables.any(ranges(), r -> 
r.intersects(session.ranges)}} instead of iterating over the ranges.
 * RepairSession#involvesTables - includesSSTables or containsSSTables might be 
a better name

> Preview repair should include sstables from finalized incremental repair 
> sessions
> ---------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-15553
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-15553
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Consistency/Repair
>            Reporter: Marcus Eriksson
>            Assignee: Marcus Eriksson
>            Priority: Normal
>             Fix For: 4.0-alpha
>
>
> When running a preview repair we currently grab all repaired sstables, 
> problem is that we depend on compaction to move the sstables from pending to 
> repaired so we might have different data marked repaired on different nodes. 
> Including any sstables from finalized incremental repair sessions as repaired 
> will solve this.
> Another problem is that validations don't start at exactly the same time on 
> different nodes, so if an incremental repair finishes while the preview 
> repair is running we might also validate the wrong repaired set. We should 
> fail the preview repair if an intersecting incremental repair finishes during 
> the preview repair.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to