[ https://issues.apache.org/jira/browse/CASSANDRA-17221?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17465118#comment-17465118 ]
Simon Chess commented on CASSANDRA-17221: ----------------------------------------- Hello, I am new to working on Cassandra, should I keep the new functions contained within the MathFcts class or should I add abs, log, exp, log10, and round to each of the NumberTypes? I'm not sure if it's better to keep things more contained or to be more object oriented. > Add Math functions > ------------------- > > Key: CASSANDRA-17221 > URL: https://issues.apache.org/jira/browse/CASSANDRA-17221 > Project: Cassandra > Issue Type: Improvement > Components: CQL/Syntax > Reporter: Benjamin Lerer > Assignee: Simon Chess > Priority: Normal > Labels: AdventCalendar2021, lhf > > We should add native Maths functions for the most common operations: > * {{abs\(x)}} returns the absolute value of the x > * {{exp\(x)}} returns the value of e (the base of natural logarithms) raised > to the power of x > * {{log\(x)}} returns the natural logarithm (base e) of x > * {{log10\(x)}} returns the base-10 logarithm of x > * {{round\(x)}} returns the closest integer to x > +Additional information for newcomers:+ > The new functions should be put in a new class {{MathFcts}} similar to > {{TimeFcts}}. > The {{MathsFcts.all()}} method should be called in > {{SystemKeyspace.functions}} > The unit tests for the functions should be put in a {{MathFctsTest}} similar > to {{TimeFctsTest}} -- This message was sent by Atlassian Jira (v8.20.1#820001) --------------------------------------------------------------------- To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org