This is an automated email from the ASF dual-hosted git repository.

edimitrova pushed a change to branch trunk
in repository https://gitbox.apache.org/repos/asf/cassandra.git


    from 2944d77aac Merge branch 'cassandra-5.0' into trunk
     add b0150e86fb Clean up KeyRangeIterator classes * replace 
KeyRangeConcatIterator's PriorityQeueu with List * remove 
KeyRangeIterator.current and simplify * remove injected exception and tests - 
not relevant to the current implementation * expand randomized testing * inline 
getCurrent() -> peek(); rename getCount to getMaxKeys * redefine skipTo 
contract to not return a value (which saves unnecessary work when skipTo is 
called multiple times in a row) * calling hasNext in skipTo is a  [...]
     new a1b0a310ed Merge branch 'cassandra-5.0' into trunk

The 1 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 CHANGES.txt                                        |   1 +
 .../index/sai/disk/IndexSearchResultIterator.java  |  39 ++----
 .../disk/v1/postings/PostingListRangeIterator.java |   2 +-
 .../sai/iterators/KeyRangeConcatIterator.java      | 105 ++++++++------
 .../iterators/KeyRangeIntersectionIterator.java    | 132 ++++++++++++------
 .../index/sai/iterators/KeyRangeIterator.java      |  99 ++++++++------
 .../sai/iterators/KeyRangeOrderingIterator.java    |   2 +-
 .../index/sai/iterators/KeyRangeUnionIterator.java |  84 +++++++-----
 .../index/sai/memory/InMemoryKeyRangeIterator.java |   4 +-
 .../cassandra/index/sai/plan/QueryController.java  |  33 +++--
 .../cassandra/utils/AbstractGuavaIterator.java     |   5 +-
 .../index/sai/disk/SingleNodeQueryFailureTest.java | 100 ++++++++++----
 .../sai/disk/v1/BalancedTreeIndexSearcherTest.java |   2 -
 .../sai/disk/v1/InvertedIndexSearcherTest.java     |   2 -
 .../iterators/AbstractKeyRangeIteratorTester.java  | 119 ++++++++--------
 .../sai/iterators/KeyRangeConcatIteratorTest.java  |  83 +++++------
 .../KeyRangeIntersectionIteratorTest.java          | 127 ++++++-----------
 .../sai/iterators/KeyRangeUnionIteratorTest.java   | 151 ++++++++-------------
 .../index/sai/iterators/LongIterator.java          |  21 +--
 .../index/sai/utils/SAIRandomizedTester.java       |  10 ++
 20 files changed, 600 insertions(+), 521 deletions(-)


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to