[ 
https://issues.apache.org/jira/browse/CASSANDRA-6157?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13866244#comment-13866244
 ] 

Jonathan Ellis edited comment on CASSANDRA-6157 at 1/9/14 3:10 AM:
-------------------------------------------------------------------

So...  not to bikeshed myself, but what format should we use here?

I suggested
{code}
{'dc1', 'dc2'}
{code}

(python set literals, admittedly somewhat obscure), other options could be 

{code}
['dc1', 'dc2']
{code}

(json list) or 

{code}
"dc1,dc2"
{code}

(CDL).  What we have here is 

{code}
{dc1,dc2}
{code}

which is invalid just about everything. :)

Suggest just switching to CDL?

(I don't think we can have a YAML construct that can be "either a string, or a 
yaml list" but I'm not an expert so I may be wrong on that point.)

P.S. We typically just use Config as a "raw values" dump and do extra parsing 
in DatabaseDescriptor if necessary.


was (Author: jbellis):
So...  not to bikeshed myself, but what format should we use here?

I suggested {{ {'dc1', 'dc2'} }} (python set literals, admittedly somewhat 
obscure), other options could be {{ ['dc1', 'dc2'] }} (json list) or {{ 
"dc1,dc2" }} (CDL).  What we have here is {{ {dc1,dc2} }} which is invalid just 
about everything. :)

Suggest just switching to CDL?

(I don't think we can have a YAML construct that can be "either a string, or a 
yaml list" but I'm not an expert so I may be wrong on that point.)

P.S. We typically just use Config as a "raw values" dump and do extra parsing 
in DatabaseDescriptor if necessary.

> Selectively Disable hinted handoff for a data center
> ----------------------------------------------------
>
>                 Key: CASSANDRA-6157
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-6157
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: sankalp kohli
>            Assignee: sankalp kohli
>            Priority: Minor
>             Fix For: 2.0.5
>
>         Attachments: trunk-6157-v2.diff, trunk-6157-v3.diff, 
> trunk-6157-v4.diff, trunk-6157.txt
>
>
> Cassandra supports disabling the hints or reducing the window for hints. 
> It would be helpful to have a switch which stops hints to a down data center 
> but continue hints to other DCs.
> This is helpful during data center fail over as hints will put more 
> unnecessary pressure on the DC taking double traffic. Also since now 
> Cassandra is under reduced reduncany, we don't want to disable hints within 
> the DC. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Reply via email to