[ 
https://issues.apache.org/jira/browse/NETBEANS-4011?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Miguel updated NETBEANS-4011:
-----------------------------
    Description: 
When using the editor feature "assign value to new variable" it would be nice

to have the possibility to configure whether the variable generated is created 
with the full type declaration or "var", either always, never or on a case by 
case basis.

 

For example:

```java
// generated now
boolean isBlank = "    ".isBlank();

 

// would be cool
var isBlank = "    ".isBlank();
```

 

Of course this would only work for local variables inside function as per 
definition

 

 

 

  was:
When using the editor feature "assign value to new variable" it would be nice

to have the possibility to configure whether the variable generated is created 
with the full type declaration or "var", either always, never or on a case by 
case basis.

 

For example:

```
// generated now
boolean isBlank = "    ".isBlank();

 

// would be cool
var isBlank = "    ".isBlank();
```

 

Of course this would only work for local variables inside function as per 
definition

 

 

 


> Allow feature "Assign Value To New Variable" to user var
> --------------------------------------------------------
>
>                 Key: NETBEANS-4011
>                 URL: https://issues.apache.org/jira/browse/NETBEANS-4011
>             Project: NetBeans
>          Issue Type: Improvement
>          Components: java - Editor
>    Affects Versions: 11.3
>            Reporter: Miguel
>            Priority: Major
>
> When using the editor feature "assign value to new variable" it would be nice
> to have the possibility to configure whether the variable generated is 
> created with the full type declaration or "var", either always, never or on a 
> case by case basis.
>  
> For example:
> ```java
> // generated now
> boolean isBlank = "    ".isBlank();
>  
> // would be cool
> var isBlank = "    ".isBlank();
> ```
>  
> Of course this would only work for local variables inside function as per 
> definition
>  
>  
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists

Reply via email to