This is an automated email from the ASF dual-hosted git repository.

acassis pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/nuttx.git

commit 65e835c779c9684c1e9d8e992540e47f420b8bd2
Author: Justin Hammond <[email protected]>
AuthorDate: Sun Aug 16 16:04:32 2026 +0800

    drivers/usbhost: Rename usbhost_xhci_pci.c to usbhost_xhci.c.
    
    Pure rename, so that the history of the driver follows it into the file
    that keeps the bulk of the code.  The PCI attachment is added back as a
    new usbhost_xhci_pci.c in the commit that follows.
    
    Assisted-by: Claude:claude-opus-5
    Signed-off-by: Justin Hammond <[email protected]>
---
 drivers/usbhost/CMakeLists.txt                         | 2 +-
 drivers/usbhost/Make.defs                              | 2 +-
 drivers/usbhost/{usbhost_xhci_pci.c => usbhost_xhci.c} | 0
 3 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usbhost/CMakeLists.txt b/drivers/usbhost/CMakeLists.txt
index cf7f8886fd0..9115f99e1c0 100644
--- a/drivers/usbhost/CMakeLists.txt
+++ b/drivers/usbhost/CMakeLists.txt
@@ -84,7 +84,7 @@ if(CONFIG_USBHOST)
   endif()
 
   if(CONFIG_USBHOST_XHCI_PCI)
-    list(APPEND SRCS usbhost_xhci_pci.c usbhost_xhci_trace.c)
+    list(APPEND SRCS usbhost_xhci.c usbhost_xhci_trace.c)
   endif()
 
   # HCD debug/trace logic
diff --git a/drivers/usbhost/Make.defs b/drivers/usbhost/Make.defs
index 07e09f0bf49..5bf8556d49e 100644
--- a/drivers/usbhost/Make.defs
+++ b/drivers/usbhost/Make.defs
@@ -85,7 +85,7 @@ CSRCS += usbhost_bthci.c
 endif
 
 ifeq ($(CONFIG_USBHOST_XHCI_PCI),y)
-CSRCS += usbhost_xhci_pci.c usbhost_xhci_trace.c
+CSRCS += usbhost_xhci.c usbhost_xhci_trace.c
 endif
 
 # HCD debug/trace logic
diff --git a/drivers/usbhost/usbhost_xhci_pci.c b/drivers/usbhost/usbhost_xhci.c
similarity index 100%
rename from drivers/usbhost/usbhost_xhci_pci.c
rename to drivers/usbhost/usbhost_xhci.c

Reply via email to