[ 
https://issues.apache.org/jira/browse/WICKET-5866?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin Grigorov updated WICKET-5866:
------------------------------------
    Fix Version/s: 8.0.0-M1

> Reconsider generics of IConverterLocator#getConverter()
> -------------------------------------------------------
>
>                 Key: WICKET-5866
>                 URL: https://issues.apache.org/jira/browse/WICKET-5866
>             Project: Wicket
>          Issue Type: Improvement
>          Components: wicket
>    Affects Versions: 7.0.0
>            Reporter: Sven Meier
>            Assignee: Sven Meier
>            Priority: Minor
>             Fix For: 8.0.0-M1
>
>
> IConverterLocator#getConverter() has a generic parameter <C> currently.
> It seems to me that this is not very useful: almost all code calling 
> #getConverter() does not care for the type parameter.
> From the user perspective it's very common to override 
> Component#getConverter(). With the need for a cast and to suppress the 
> generics warning, providing a custom converter is much too hard currently:
> {code}
>     public <C> IConverter<C> getConverter(Class<C> clazz)
>      {
>          if (Date.class.isAssignableFrom(clazz))
>          {
>              @SuppressWarnings("unchecked")
>              IConverter<C> result = (IConverter<C>)converter;
>              return result;
>          }
>          else
>          {
>              return super.getConverter(clazz);
>          }
>      }
> {code}
> I propose to remove the generics parameter from the method.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to